Ford Mustang Forum banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
After adding an induction system to my 2000, I get a whistling sound at certain rpms during acceleration and the gas mileage has dropped about 3mpg (not due to lead foot). Any thoughts?
 

·
Registered
Joined
·
1,871 Posts
the "whistleing" or "sucking" sound your hearing might be a vaccum line, make sure you have them connected. Na did you reset your ECU after you installed it? Gas mielage can be due to weather and some other factors.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
MAF screen?

I don't think it is a loose hose, but thanks for that thought. I did leave the MAF screen out and now am having second thoughts since the whistle is so annoying - will try anything. I also have been making quarter twists on the air sensor in hopes repositioning it will solve the problem if it is air whistling through the shield around it. I thought I disconnected the battery, after installing, but in any event I had to get a new battery last week so I will be checking mileage in the next day or two to see if it still is bad.
 

·
Registered
Joined
·
1,871 Posts
It is normal for the MAC CAI to have a sucking sound to it. It is more present when the A/C is running. Nothing to be alarmed about.
 

·
Registered
Joined
·
11,432 Posts
2+2 said:
I don't think it is a loose hose, but thanks for that thought. I did leave the MAF screen out and now am having second thoughts since the whistle is so annoying - will try anything. I also have been making quarter twists on the air sensor in hopes repositioning it will solve the problem if it is air whistling through the shield around it. I thought I disconnected the battery, after installing, but in any event I had to get a new battery last week so I will be checking mileage in the next day or two to see if it still is bad.
The MAF should be completely level. This CAN affect your gas mileage . ..
 

·
Registered
Joined
·
173 Posts
I never thought about it, but does the computer have to be reset if you add a new mass air meter, not the computer part but the tube and a CAI? If so is it just a matter of unhooking the battery and for how long, thanks!
 

·
Registered
Joined
·
11,432 Posts
StangLx50 said:
I never thought about it, but does the computer have to be reset if you add a new mass air meter, not the computer part but the tube and a CAI? If so is it just a matter of unhooking the battery and for how long, thanks!
Yeah, you should disconnect the battery for a couple of minutes. When you reconnect the battery, drive it like hell for the 1st 5-6 starts for the computer to learn a performance tune.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
Okay, I filled up and am getting 18mpg city. How does that stack up--V-6, manual, somewhat hilly terrain, a/c on about half the time? Thanks for the tip - I'll check to see if the Mass Air is level.
 

·
Registered
Joined
·
1,871 Posts
stock should be about 26 hiway 19 city, add ac and youll drop down a few points, add in hills and your looking around what your getting.
 

·
Registered
Joined
·
2,579 Posts
18 mpg in the city is about average.
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top