Ford Mustang Forum banner

Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 99 Mustang GT with the MACH 460. I changed the head unit with a Kenwood KDC-959 and connected it using a harness I had leftover from my 94 PROBE GT (hey it fit). Sometime later I had a problem with a slow battery drain which the dealership found to be an amp which they disconnected (I later discovered it was the rear driver side amp). The radio played fine so I thought nothing about it. The drain stopped until I moved and left the car in a storage garage for approx 3 months and disconnected the battery. When I reconnected the battery not only did the drain come back but I have no bass! I disconnected the passenger side rear amp and the drain issue was solved.

I want to use the factory wiring (otherwise its $200 to have the car rewired) so I bought 2 new rear amps on e-bay but I'm not sure which wire harness to go with. Crutchfields directs you to the Scosche FDK 5 but the only difference between that and what I have is the gain adjuster, at least to a non radio savvy person like myself. I've also read that the Scosche FDK10 (again seems to be what I already have) or Scosche FDK 1 (RCA's connectors which seems to be the way to go) will work. I just don't want to blow money (even though we are talking only a few dollars) on a harness and have a power drain but I don't want to pay the big bucks for replacing everything (amps, speakers and rewiring) which would definitely fix the problem.



Any suggestions/recommendations would be appreciated.
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top