Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Not sure why but when I rev the engine while in park or nuetral (no load) I get a pretty serios backfire pop(s) from the exhaust? I know its a magnaflow muffler w/ cats. Whats the problem? Lack of backpressure? Any help??
 

·
Registered
Joined
·
5,329 Posts
First guess would be its running rich or maybe the ignition is weak, something is letting it load up unburnt fuel... does it have cats?
 

·
Registered
Joined
·
3,600 Posts
did you install an x pipe? they tend to crackle and pop quite a bit more than the h pipes.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Loadup??? Backfires?

It does have cats and they look smaller than what I would have expected? It also has an H pipe not an X pipe. If its running rich or has weak spark what would be the most efficient way of dealing with that? I dont have a tuner or anything. Maybe plugs and wires? It does have 80,000 miles on it? I'm pretty mechanical so is there any adjustments I can make myself? Its not a daily driver so I would prefer it ran a little lean than rich, Any ideas???
 

·
Registered
Joined
·
5 Posts
good plugs and wires should solve the problem if that doesn't it might be the coil i would recommend Bosch platinum +4 plugs I put them in my 96 and it made a HUGE difference
 

·
Registered
Joined
·
136 Posts
happens in mine sometimes but only when engine is totally cold, or if im coming down from sustained high rpms, if you have the magnapacks on there it is fairly normal for them to sound perform like this. if you are concerned enough give magnaflow a call and ask.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top