Ford Mustang Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
897 Posts
Discussion Starter · #1 ·
My 1st year goals were to
1) get a 60ft time of less than 2.00 on the factory tires which I accomplished 2 weeks ago with a 1.95 60ft.
2)Get below 13 Seconds with a minimum of performance mods which I accomplished with just a C&L intake and a Diablosport Predator on BFG Drag Radials.
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #3 ·
NewPonyGuy said:
:worship Very Nice.

Looks like cardomain is down, I could not get to your site.
Thanks,

Relocating onto larger servers or something.
 

·
Registered
Joined
·
5,003 Posts
thump_rrr said:
My 1st year goals were to
1) get a 60ft time of less than 2.00 on the factory tires which I accomplished 2 weeks ago with a 1.95 60ft.
2)Get below 13 Seconds with a minimum of performance mods which I accomplished with just a C&L intake and a Diablosport Predator on BFG Drag Radials.
http://i24.photobucket.com/albums/c40/Thump_rrr/Sub13Sec.jpg
Nice! Just back from the track myself, and not even close to breaking 13!

Did you change your gearing or is that mostly from suspension parts?

I guess you're to the left on the slip? If so you broke your 60 record too!!

I know I can't do better than 13.5 with my current set up... but soon it will be better!
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #5 ·
kj_cinci said:
Nice! Just back from the track myself, and not even close to breaking 13!

Did you change your gearing or is that mostly from suspension parts?

I guess you're to the left on the slip? If so you broke your 60 record too!!

I know I can't do better than 13.5 with my current set up... but soon it will be better!
The gearing is still stock.
The only suspension mod which definitely helped is the Steeda Third Link which eliminated the wheelhop I would sometimes experience.

The swaybars and the sport springs don't help at the track because they don't allow the front end to lift transfering the weight onto the rear wheels.

Even though I go to the track twice a week I'm setting up the car for roadrace rather than drag.

What is your setup?

Mods? Tire pressure? launch RPM?

What were the track conditions? air temp, track temp, humidity, was there glue?

Just to give you an idea what the car ran stock with 300km(180Miles) on it.
Stock 2.097 60Ft. ,8.857 1/8th Mile , 13.638 @ 104.473
 

·
Registered
Joined
·
5,003 Posts
Me too have a road race set-up with Eibach Pro Springs and sway bars... The upper control arms are quite a bit beefer on the Eibachs than stock was...

I have never experienced wheel-hop, not even during the burn outs...

I should be around 300 RWHP with a cone filter/MAF, CMDP, UD pulleys, an after cat X, and axle-backs, with a (many!) professional custome tune (s)... I also have a short throw and MT ET Streets.

Started at 17 PSI in the tires and ended up at 13. Spun a bit on take off pretty much every time I tried to drop it... no way at 4,000 RPM! Learned that I was best of at about 3000 with a bit of clutch feathering at the third yellow...

Track was a bit slippery the 'pros' said... there was some glue (they put it on for the big boys.) It was cold, maybe 50 F, ~10 C and windy, overcast, no idea about track temp... It had been raining for 24 hours before but the track was obviously dry since they were open...

I was about .8 worse on a track in worse shape with my regular tires last weekend so I was happy with the improvements...

This is the 2nd fastest S197 they've seen they said... they make fun of them at the tracks here... sticks are closer to 15 than 14, autos do better....
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #7 · (Edited)
kj_cinci said:
Me too have a road race set-up with Eibach Pro Springs and sway bars... The upper control arms are quite a bit beefer on the Eibachs than stock was...

I have never experienced wheel-hop, not even during the burn outs...

I should be around 300 RWHP with a cone filter/MAF, CMDP, UD pulleys, an after cat X, and axle-backs, with a (many!) professional custome tune (s)... I also have a short throw and MT ET Streets.

Started at 17 PSI in the tires and ended up at 13. Spun a bit on take off pretty much every time I tried to drop it... no way at 4,000 RPM! Learned that I was best of at about 3000 with a bit of clutch feathering at the third yellow...

Track was a bit slippery the 'pros' said... there was some glue (they put it on for the big boys.) It was cold, maybe 50 F, ~10 C and windy, overcast, no idea about track temp... It had been raining for 24 hours before but the track was obviously dry since they were open...

I was about .8 worse on a track in worse shape with my regular tires last weekend so I was happy with the improvements...

This is the 2nd fastest S197 they've seen they said... they make fun of them at the tracks here... sticks are closer to 15 than 14, autos do better....
It must be a traction issue.

Does the track have a concrete launch pad?

Were you running at tri-state dragway? If so it does.

I ran my best at 9c or 49F with an 11kph (7mph) cross wind.

A friend of mine is running [email protected]

He has M/T ET Streets with skinnies up front a Steeda cold air intake,Sct X-cal II, magnapacks, prochamber and 4:11 gears

HERE
 

·
Registered
Joined
·
5,003 Posts
Dunno about the tracktion... would love to blame that! :winks I think I had pretty good tracktion Saturday... It was at Tri-State... I know what bad tracktion feels like as I had that last weekend at Edgewater...

Your friends gearing should be helping at least .5 of a sec I've been told...

I have by big a$$ 275-35-19 in front, plus the suspension parts, not good for weight transfer!

Maybe I just need some more practise... Saturday my clutch started to give (mostly smell, heard/felt som slip 2nd to 3d) after run 4 or so...

This coming weekend I'll try to take some weight outa the car, not have a full tank of gass and all of that... I'll also try to get some more heat in the tires and start at 13 PSI at the get go...

I might also have more power (cheating?) as it seems we're finally going to get my P&P heads on... power should help! :tongue
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #9 ·
kj_cinci said:
Your friends gearing should be helping at least .5 of a sec I've been told...
He only does one mod at a time.

[email protected] stock

[email protected] skinnies and M/T ET Streets

[email protected] MAC Pro Chamber and Magna Packs

[email protected] My 87 Predator tune with Factory Intake (Last Minute Idea)

[email protected] Steeda CAI with X-Cal II Custom Tune

[email protected] 4:10 Gears

kj_cinci said:
Maybe I just need some more practise... Saturday my clutch started to give (mostly smell, heard/felt som slip 2nd to 3d) after run 4 or so...
I told you not to do more than 2 runs without letting it cool off.

I'm going with a Centerforce Dual Friction since it has about 90% more force but keeps more or less the stock pedal feel.
 

·
Registered
Joined
·
5,003 Posts
Cool, he has a nice running car and is obviously a good driver!

I have 10 runs under my belt on the strip in a car... maybe 200 on a bike... the rest of my racing was on road courses in M3s... So I guess I'll learn...?!?

I let it cool allot... was there 4 hours for 7 runs... did a couple back to back just for compairson... as you know that's what I do now... test and try...
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #11 ·
kj_cinci said:
Cool, he has a nice running car and is obviously a good driver!

I have 10 runs under my belt on the strip in a car... maybe 200 on a bike... the rest of my racing was on road courses in M3s... So I guess I'll learn...?!?

I let it cool allot... was there 4 hours for 7 runs... did a couple back to back just for compairson... as you know that's what I do now... test and try...
Ted has 15 years experience. His consistency is amazing. I'm sure your times will improve with time.

We only have 1 week left before our track closes for the season :sosad:
 

·
Registered
Joined
·
5,003 Posts
Yup... I got it... the guys at the shop told me today... my burnouts suck! :sosad:

I have to swing by the shop for a 'burnout class' and practise on the way to the track Friday (or Saturday depending weather...) with the stickies on of course... didin't count with my reg tires in the rain today... :tongue

Then I should be able to jump of the line better, get a sub 2 60 and low 13s 1/4...?? :dunce:
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #13 ·
kj_cinci said:
Yup... I got it... the guys at the shop told me today... my burnouts suck! :sosad:

I have to swing by the shop for a 'burnout class' and practise on the way to the track Friday (or Saturday depending weather...) with the stickies on of course... didin't count with my reg tires in the rain today... :tongue

Then I should be able to jump of the line better, get a sub 2 60 and low 13s 1/4...?? :dunce:
With ET Street Radials on an 05 GT your 60ft should be in the 1.7-1.8 range from what I've seen at 4 different tracks. 2 in Quebec 1 in New Jersey and 1 in New Hampshire
 

·
Registered
Joined
·
5,003 Posts
Yup, I suck, my burnouts suck... need practise! :winks
 

·
Registered
Joined
·
273 Posts
kj_cinci said:
Nice! Just back from the track myself, and not even close to breaking 13!

Did you change your gearing or is that mostly from suspension parts?

I guess you're to the left on the slip? If so you broke your 60 record too!!

I know I can't do better than 13.5 with my current set up... but soon it will be better!
which strip are you using KJ? tri-state or edgewater? i'd like to come and watch ya run that puppy. lol
 

·
Registered
Joined
·
5,003 Posts
005 GT said:
which strip are you using KJ? tri-state or edgewater? i'd like to come and watch ya run that puppy. lol
Both... will be at Edgewater if it's not raining tonight... looks bad... if it's nice tomorrow I'll go to Tri...
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #17 ·
I installed my Steeda Underdrive Pulleys yesterday so I went back to the track last night. This is our last weekend of racing before the track closes down for the winter :sadcry: The traction sucked but the air was good.

Air temp 35F.

Best run: 2.127 60ft. 8.587 1/8th mi. 13.203 @ 111.320 :shocked: mph!!!!!

Worst run: 3.180 60ft. 11.031 1/8th mi. 16.012 @ 102.631 mph!!!!!

I wll be going back this afternoon. The forcasted temp is 48F
 

·
Registered
Joined
·
5,003 Posts
Nice speed!

I'm going to Tri-State today and it's coold here too so hopefully I can get some grip and a good run in!
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #19 ·
I went back to the track today trying to see what gains I could make by installing the Steeda Underdrive pulleys.

The weather was 47F. and traction was still an issue with 60ft times .05 slower than last week.

I ran a 12.821 @ 111.273MPH. an improvement over my 12.95 @ 106.99 MPH.

Tomorrows' forcast calls for 59F and sunny. We'll see how much the temperature will affect my times.

Keep in mind it's a fairly stock 05 GT with a C&L Intake, Diablosport Predataor, Steeda Underdrive Pulleys on BFG Drag Radials.

The Steeda suspension is setup for roadrace and not for drag.
 

·
Registered
Joined
·
5,003 Posts
Congratz Thump!

Me too made it to the track today... finally got a 60 under 2 and polished my best to 13.43... the goal for today was to perfect the burn-outs and get under 13.5. Both are taken care off... low 13's nest weekend!?!

I still have some issues off the line... might need to drop the clutch quicker...?? Will try next weekend...
 
1 - 20 of 30 Posts
Top