Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter · #1 ·
I added a MSD Blaster coil to my 92 5.0,now here is the problem.When i first started the car up all i could here is this hum type pitch like a transformer would make.I took the car for a ride and it did not miss and ran fine even to 5800 rpms.I pulled into my garage and popped the hood in the dark with the car running and the MSD Blaster Coil was sparking blue on each side of it,so i put my stock coil on and the hum is gone.Do MSD Blasters normally hum and spark blue like that?You sure can tell the difference when you have the MSD coil on because in the dark even with brand new 9mm Motorsport wires you still see a couple blue sparks here and there one was right at the plug boot,now is that normal? I just want to make sure i did not get a screwed up coil or something,i bought the coil,cap,rotor and wires new from Jegs.
 

·
Registered
Joined
·
165 Posts
i think you might have a problem. i have a blaster coil and it doesn't hum. then again, i have a loud a$$ electric fan. :D
 

·
Registered
Joined
·
251 Posts
I had a blaster coil on my old 88, and it did the same thing. Im not sure about the blue sparks, just the humming.
I thought something was wrong aswell, so i carried around my stock coil in my car for about a year in case something happend, but it was fine. The humming got less and less with every kilometer aswell, but you could definitely still hear it if you knew what to listen for.
If you think its a big problem, or hate the noise, send that stuff back... otherwise, I think you'll be fine mechanically. Like i said, mine did the same thing, and my car ran perfect on the street, and at the track.
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #4 ·
Phoned MSD they said to mount it on rubber in behind the coil.I did that and i also put rubber under the bracket that mounts to the strut tower and the humm is gone.If you put your ear right to it you can here it if you know what your listening for.

As far as the blue spark on each side of the coil,MSD said that is totally normal for that coil and that most people don't notice it because they put that plastic cover back on and most peole don't look at there coil at night when it's pitch black.
I guess it's fine,i hope.
Thanks to all that replied........:thumbup
 

·
Registered
Joined
·
77 Posts
good to hear that coil is suppose to do that cuz i was wondering about mine. but i dont think putting ur ear next to the coil while u can see blue sparks fly is a good idea. that might hurt a bit.
 

·
Registered
Joined
·
2,975 Posts
mine does that on my 93 but its wierd because it doesnt do it on my ranger and i have the same coil. different wires though, im running jba wires on the truck
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top