Ford Mustang Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
OK Guys I need your help here,Some time ago some one had a post on the wiring of 1988 mustang o2 sensors.Here is my problem.As I have mentioned before I have a 1988 Mazda RX7 with 1988 mustang lx 5.0 EFI with AOD. when this eng was speed density it ran great in the car and since I have converted to mas air I am still working out the bugs.I have all new parts plugs wires rotor ect ect. New act,tps, ect. I have replaced all the vacum hoses pcv and the grommet it sits into.I have 3 A9P computors and I used the stock mas air From my Roush truck (calibrated for 19lb injectors) The codes I get are 41 and 91 Lean on left and right side.I have the typical useless codes since I removed my egr and smog during the swap.I read some where that these codes are caused by a bad timer to the o2 sensors but I could be wrong.On my mustang wiring diagram it shows that both o2sensors use a ground going to the firewall then to the eng.Here's what happened,I installed the first computer and it was bad,installed the second computer and did all the setups and the car ran good not great.I drove it for a couple of days and it started to hunt at an idle until it would stall out and it kept getting worse.So I pulled the codes and got 41&95.So i installed my last computer and started the car up and it never sounded better,went for a long drive with stop and go then a short run on the hiway and I noticed every time I stopped at a light it started to run rough at an idle.So I got home and pulled it into my shop and the bad idle was back as in the second computer.So my question is this,is there a timer for the o2 sensers(I didn't see it on the diagram)or did I simply miss the ground for the o2 sensers?:headscratch:
 

·
Registered
Joined
·
5,170 Posts
The O2 sensor ground should is usually located on the back of the intake or head. Its orange in color and has a ring terminal on it. The ECM is what controls the switch rate( or timer as you call it). Make sure that ground is hooked up. Its number 19 in the diagram below. The HEGO ground is ran to PIN 49 at the ECM if you choose to run another one for some reason. If the ground is already hooked up, make sure the connection is good, and check the wire for resistance. Should be 0-5ohms with ECM and HEGO ground unhooked

 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
Thanks for the quick reply,When working on the car last night,I did notice an orange wire that looked like it had been cut and stuffed into the split loom on the harness.I will check the continuity on this and if it is the ground I will hook it up and see what happens.If it works this will be the second time in a week that someone has cut a wire on me and stuffed it back into the split loom.Had this happen to me at work on thursday.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
Hey Man I owe you big time.If you didn't live so far away I would ship you a case of canadian beer.MY donor car(1988 LX) was hit real hard in the front end and the engine was pushed into the firewall,It looks like the orange wire had been crushed and when I removed the harness the wire retreated into the loom.I did a continuity test from the orange wire to pin 49 on the ecm and BINGO was called.Hooked the orange wire to eng ground and the car ran GREAT,took it for a drive to let the ecm reset and this is the best it has ever run.:happyhapp:D:happydance: Now I can't wait to install the new eng.1990 roller .030 over,flattops,185 AFR alum heads,e303 cam,1.6 roller rockers,GT40 upper and lower intake,75mm power products throttle body and 80mm mas air calibrated for my frpp24lb. injectors.Thanks again:wavey:bigthumbsup
 

·
Registered
Joined
·
5,170 Posts
The case of beer is temting enough to make me move closer.. LOL glad you got it fixed
 

·
Registered
Joined
·
5,170 Posts
Oh Yeah!!! Since your Canadian( Or Live in Canada) Hail GSP! Aint he the badest MF'r in UFC
 

·
Registered
Joined
·
39 Posts
Discussion Starter #8
Ya I live on the west coast of canada in british columbia.I am about a easy 5hr.drive from seattle.And you know what? Tonight, after detailing both my vehicles for the big car show tomorrow,I am going to relax with a beer and have one for you.Sure hope it tastes good?:happydance:
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top