Ford Mustang Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
Please help. I recentely put JBA longtube headers and a o/r h-pipe on my 2006 gt(with sct tuner). Of course the sensors wouldn't reach so the check engine light is on. So i got extensions for the sensors on the headers. I already had a sct tuner so american muscle sent me a tune that should have lied to the computer so i didn't have to purchase simulators for sensors in the h-pipe but it did not work. I still have the check engine light on and i don't have a clue why. Any one have a solution or idea to fix the problem?
 

·
Registered
Joined
·
725 Posts
With the sct tuner select rear o2's and select off if you havnt already. If it still stays on with the o2's off then maybe its somthing else. Do you have the code it's givin you
 

·
Registered
Joined
·
83 Posts
Discussion Starter #3
Yes the codes are P0155 that says o2 heater (htr 21) ckt (b2,s1) and the other is P0135 that says o2 heater (htr 11) ckt (b1,s1)
 

·
Registered
Joined
·
725 Posts
Well thats the o2's. Are the plugs swapped? I know it sounds dumb but we had a guy at the shop havin problems with o2 sensor codes and he swapped the upsream with the downstream while installing headers.
The o2's are off right? If they are then im stumped.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #5
I probably did....I switched them around because when i went to put the extensions on the sensors in the headers they wouldn't plug in so i thought i had them wrong so i swaped them and they plugged in fine but the trouble codes were still on.
 

·
Registered
Joined
·
12,666 Posts
you've got 4 O2 sensors and the tuner will only disable the rear ones, the forward ones you need to have enabled for your A/F ratio. have you gotten tuned for your mods?

I'd take it to a dyno and see if your AFR is off or not tbh
 

·
Registered
Joined
·
83 Posts
Discussion Starter #7
Yes the tune i have knows i have the mods i have. I just cleared the DTC codes after i put the extentions on the front sensors and the check engine light went off. So i went to test drive it and it didnt come back on and seemed to be running great. Hopefully it doesn't come back on tomorrow...
 

·
Registered
Joined
·
1,495 Posts
I got my lt tune from am and the 91 race tune is good but the 87 will trigger both those codes same as you? More of a reason for the extra torque :winks
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top