Ford Mustang Forum banner

Status
Not open for further replies.
1 - 20 of 38 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
hey guys,
Well i got my xcal3 on New Years and installed the custom tune and the gains were modest and the shifting is nice and firm, but now when i cold start my car the car revs up to about 3500 rpm's screaming :wavey"hey look at me":wavey. any idea why this is and how to correct it, also now after the custom tune there is a 5 to 6 second delay from when you press the gas and when the car moves off the start. a huge delay in throttle response. any help would be appreciated. thanks
 

·
Registered
Joined
·
13,170 Posts
Where did you get the tune?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3

·
Registered
Joined
·
1,627 Posts
Might try disconnecting the battery to reset the ecu if you haven't already.

Sounds like the throttle position sensor isn't reading correctly. But would help to reset the ecu before trying to diagnose.
 

·
Premium Member
Joined
·
72,878 Posts
That's very common on aftermarket tunes. It can be adjusted. Disconnecting the battery will do nothing.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #8
not yet, ill try that tomorow< thanks, they gave me 2, an 89 and 93 octane tunes
 

·
Registered
Joined
·
336 Posts
Get a Brenspeed, Bamachips or Tillman tune.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #11 (Edited)
yes sorry, i got the xcal3 or x3 from modular depot. and "they" loaded 2 tunes for me :nono: :bigthumbsup im trying the 89 oct. today.hell im going to try it right now. im going to load it cold and see if that changes anything.:happyhapp
 

·
Registered
Joined
·
191 Posts
yes sorry, i got the xcal3 or x3 from modular depot. and "they" loaded 2 tunes for me :nono: :bigthumbsup im trying the 89 oct. today.hell im going to try it right now. im going to load it cold and see if that changes anything.:happyhapp
Waiting....:sleeping:
 

·
Registered
Joined
·
191 Posts
Chetty, were you able to check to see if your current PCM code matches the one on the sticker on your CPU?

This is my biggest worry. I am having tunes made by Tillman based on that sticker, and I'm not certain that's the correct code as my car was in for warranty work several months back, and I believe they flashed the PCM. I won't know for certain until my X3 arrives. BTW, does anyone have the strategy code conversion table? The code on my CPU is XZE2.
 

·
Registered
Joined
·
191 Posts
Of course......:bigthumbsup I'm just tring to help they find some great quality for the money.
I hope so too. Chris and I yapped for almost 90 minutes the other day! Great dude. I'm just worried that my PCM code may be different than what is on the sticker. Chris hasn't gotten back to me on that yet.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #19 (Edited)
i switched to the 89 oct tune car seems to be the same. it started up the same.1k then 2k then "hey look at me 3k rpm". but it goes down fast. i just hope that it doesnt oil starve being a cold start.:laugh:. i think my throttle probs are a tps issue. does anyone know if that can be adjusted. i read from the manual here at Ford Service Manuals - S197 but that was pretty technical. it just seems like i have to press it exsessively to get that first inch or it has to much play.sounds like a lead foot problem.lol any ideas? and thanks guys. this site rocks.
 

Attachments

·
Registered
Joined
·
34 Posts
Discussion Starter #20
yup my #s match:)
 
1 - 20 of 38 Posts
Status
Not open for further replies.
Top