Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have 2000 ford mustang 5 speed v6 3.8l. It has 135,000 miles. Did the Oil changed, Front and back breaks changed out the rear suspension and everything seemed okay. The other night was driving back from work. We had a real bad rain storm and the humidity was horrible. I was driving down the highway doing about 60. The car starts making this weird chattering noise under the hood. Sounded like the serpine belt was smacking under the hood. I pull over lifted the hood while the car was running and still heard the noise but the serpintine belt was fine. The car was sounding really ruff so I turned her off. When I look towards the back of the car its smoking dark thick smoke out the exhaust. I smell this sweet smell coming from the car weird stuff. I check the fluids everything good. OIL FINe, ANTI FREEZE FINE, NOT OVER HEATING. Battery lamp good. WEIRDEST thing ever happened to me. Make a long story short car wont turn back on. It wont turn over or nothing. sounds like the car is shocking itself when I turn the key. The batteries dead now but was okay before I worked her over a bit so thats probably my fault plus the alternator is new I put her in myself. What died Timing chain, seized engine, something locked up in that car cant put my finger on what it was though. Please help.
 

·
Registered
Joined
·
682 Posts
im too tired to read the wall of text but if it cranks but dosent turn over its a dead battery other then that idk haha
 

·
Registered
Joined
·
8,348 Posts
Do you have a cold air kit on it? Do you still have your fenderwells on it? It sounds to me like you got water in your intake and bent a rod. I would also suggest that you look under the car and trace the wire from the starter up to your PDI box next to the battery. Also, check the PDI box for loose wires. A dead battery is usually a sign of a short. Put a 21mm socket on the harmonic balancer, and see if you can turn the motor over by hand.
 

·
Registered
Joined
·
1,544 Posts
+1 to Shiner... sounds like you got water in the engine! Follow the tests he recommended...

Now you said your coolant (anti-freeze) was fine 'cause the engine keeps temp... but did you look at the coolant? Anything floating in it?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
I can't tell if anything is floating. The Oil level and anti freeze is low. The car doesn't want to turn over. I went to auto zone and explain exactly what happened to the car and they said it sounded like the head gasket may have went. Does anyone know if the catalyic converter may have aided in the damage that was done to the gaskets.
 

·
Registered
Joined
·
1,544 Posts
Where did catalytic converter come from? That would not have any effect on the head gasket. I still think your main issue is that you got water in the engine somehow -- which may lead to a head gasket problem, but also other issues (like a bent rod, chattering noise, etc.)

And you really need to make sure your fluids (anti-freeze & oil) are at the proper levels -- it won't help if they're low...
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top