Ford Mustang Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
I continue to clean and replace parts in my car trying to control the cooliant temp i am really at a loss with this car here is the list of the parts that i have replaced all of the old cracked and spongy hoses the thin radiator with an fluidyne aluminum piece a flow kooler 180 stat a high flow water pump a proform electric fan that flow 2800cfm a new ac condencer i heard that the egr valve can cause bad idle poor fuel econemy and possible cooling problems so i am going to clean the carben build up if it has any with mass air cleaner it seems to work good for that if that does not help what else could be the problem with the cooling with this car it seems to never end with this thing i am just about ready to sell it becuse every thing that can go wrong with this car it will so any help well be great i dont want to sell or junk it but i am just at a loss please help:happyhapp:headscratch:
 

·
Registered
Joined
·
46,020 Posts
What temp does it run at? Some engines just run hotter than others. Plus there's LOTS of things that can cause it to run hot like improper air/fuel ratio, running overly lean or rich, too much timing.
 

·
Registered
Joined
·
207 Posts
Discussion Starter #3
it got overe 220 mybe 240 deg my fan has an ajustable thermostat that goes from 180 to 240 i drove for about 25 min driving it very softly and my temp gauge was reading 3/4 of the way up and i got out of the car and turned the adjustable stat all the way up and the fan never turned off i also put a meat gauge next to the fan gauge and it shot straight to 220 that is as far as the meat guage goes
 

·
Registered
Joined
·
547 Posts
did you read the instructions on the fan? some fans need the thermostatic lead near the radiator instake and some need it but the radiator exit where it goes into the engine, another thing is are you sure you got the thermostat in correctly, another thing is, is you coolant correctly mixed, is the system free of any air, did you turn on the heat while bleeding the system?
 

·
Registered
Joined
·
621 Posts
Important to know. How did it all work before you added the cooling fans and all the trick stuff?

When you added the cooling fans, you didn't reroute the belt so it spins the water pump backwards did you?

The CFM of the fan by itself isn't a good number to go by. The fan has to move air through ALL of the radiator face equally, or better yet through the hottest areas of the radiator more than the coolest, and you have to know the air flow with the restrictions in place.

To solve the questions about sensors, lock the fan on. Does it do OK with the fan locked on?

(My car has a factory clutch fan. I see no reason to pull energy from an alternator at 50% efficiency, store it at 50% efficiency in a battery, and then run a motor at 50% efficiency to turn the blades of a fan. Not for a street/strip car.)

Tom
 

·
Registered
Joined
·
172 Posts
I've seen people put the thermostat in wrong, check timing and is the fan pushing or pulling?you could have a bad head gasket
 

·
Registered
Joined
·
207 Posts
Discussion Starter #7
the car ran very hot before all of the mods the thermostat was put in with the face of it facing the radiator and the bleeder vavle in the 12 O clock and the fan before i put it in i called proform about the instructiona becuse the sucked they tolled me to put the thermostat in the corner and was told by them to push it through the fins on the top right hand side the radiator is clean of debri so is the ac condencer the cooliant is 50/50 car still ran pretty hot before i put in the high floow water pump yes it is a reverse rotation pump and it helped but if i drove the car hard it would get hot and have trouble cooling back down and with stock timing when it would start to get hot the engine will start to ping so i started to run premuim fuel and only shell gas goes in my car so today i took off my egr valve and spacer the throutle body the egr valvle was packed with corben cleaned it with throutle body cleaner just to see if that helps becuese my intown gas milleagev is about 6-8 mpg i but i have had as good as 26.6mpg highway i drove 37miles on one tank going 75mph anyway what is strang to me is somtimes if i drive the car realy hard the car will run pretty cool and not get hot and not ping:im confused:
 

·
Registered
Joined
·
460 Posts
what is your oil pressure? Also what way do you have the water pump spinning it should be spinning counter clock wise.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top