Ford Mustang Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
My check engine light came on the other day so I took it and had the computer scanned. It came up with code 1516 see dealer. The guy said that it was not a big dseal because if it was a sensor or anything else wrong with the car the the computer would have read the code. So at this point he cleared the computer. Well today on my way home I was driving down the highway so I got on it a little.:winks When I did this the check engine light came on again. I am almost wondering if it is the gas cap because it has not been replaced and when I go to tighten it, it just starts to click and wont really tighten. Would this be my problem or has anyone else had this happen to them.
 

·
Registered
Joined
·
5,907 Posts
If it was the gas cap you'd get a code for an evaporative emissions leak, a completely different code.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
Thats what I was thinking, but it just gives me a code that tells me to refer to dealership. Thats when the guy said that its not anything major, but its annoying the hell out of me. It only seems to do it under heavy throttle conditions. I just dont know what to do. I unhooked the battery tonight and I am going to see if it comes on again. What about the oil level. Could that do it if the level is to high or to low.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #4 ·
I found out that the code is for a Intake Manifold Runner Control Input Error (bank 1). Does anyone know what this means or what the fix for it is?
 

·
Registered
Joined
·
5,907 Posts
Is this on your Cobra? If it is what I'm thinking, it could be pretty expensive. The Cobras in the late 90's and up to 2001 ( I think ) had little flaps or valves inside the intake manifold that redirected airflow inside the manifold during different throttle positions and engine speeds. This kept air velocity inside the manifold at an optimum speed. The code you're describing sounds like you may be having a problem with one of these flaps. I have never heard anything about the repairs and how much they cost. Sorry I can't help you out more.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #6 ·
Yeah it is on the Cobra. The thing that concerns me is that everything is fine at normal driving, but at high speeds or heavy throttle it triggers the light. If it is the flaps that you are talking about, I am wondering if they are sticking or broken. I am thinking about cleaning it out and seeing what that does.
 

·
Registered
Joined
·
5,907 Posts
Well the flaps reposition at higher engine speeds so the fault is probably being triggered by the flaps trying and not being able to move for whatever reason.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top