Ford Mustang Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Ok guys I just purchased a 2007 GT only has 65k on it and is in perfect condition. It had a few mods when I got it. 62mm Ford racing throttle body, long tube headers, complete pypes exhaust system, cai, lowered, imrc delete, msd coils, and 410 gears. It ran beautifully for about a week. It started to get an intermittent miss, I put scanner on it and had a p0304, p0307 and a p0300, naturally I put a set of plugs in it, oem motorcraft... nope wasn't that, changed all the coils because its not throwing a code, not that either. It doesn't run bad all the time but seems to get worse the more I drive. It has a definite lean pop on hard acceleration and decal, so now I think that with all the mods that have been done it must have a tune maybe that is bad.... Downloaded a bama tune and installed it nope still runs like ****, get into a higher gear and it gets even worse, so I have changed the following parts chasing this problem, fuel pump (motorcraft) tp, maf, fpdm, altenator, fuel pressure sensor. Its definitely a fuel problem heavy or wot its not getting fuel, if your gentle with the throttle it will accelerate but I can tell its still lean. I am wide open to suggestions I need to get it fixed to take it on a trip.. Thanks
 

·
Registered
Joined
·
3,601 Posts
Downloaded a bama tune and installed it nope still runs like ****
That could be your problem. I suggest you do some datalogging and e-mail the file to Lito, who I'm sure will write you a much better tune than Bama's.
 

·
Registered
Joined
·
1,349 Posts
Id like to have stock in Lito's company, he sure has gotten a lot of business from here and other forums lately. OP, have you tried a new fuel filter? if you can, I would also recommend going to a stock size throttle body. I also agree with Bullitt, get away from the sh!t Bama tune and go with a more reputable company like Brenspeed or Lito as mentioned. good luck
 

·
Registered
Joined
·
235 Posts
Trouble shooting video on code p0300.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
The tune isn't the problem. The problem existed before I got the tune. Yes I replaced the fuel filter that was first thing I did. I was just data logging it and check engine light came back for #s 4 and 7. The tp voltage seems to be a tick off and so does the etc. this thing was great for a week now it's like Pandora's box. Worst part is short of the actual ford shop manual I have any tool I could ever need. I know it's going to be something stupid. But I am going to burn a piston if I keep going like this.
 

·
Registered
Joined
·
517 Posts
I didn't see a fuel filter on the list of parts replaced. Have you changed that?

In any case, a datalog should tell the tale and a seasoned tuner such as Lito or Don Lasota will be able to pinpoint the issue for you. So you don't have to continue throwing parts at it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Valuable lesson learned here guys. Pay close attention to the spark plugs if your not the only person that has worked on your car! I took out the motor crafts that I had just put in a week ago as I inspected the holes I noticed an excess of anti seize cleaned coils and plug holes put it back to stock runs great. ( when I put the motor craft plugs in I did notice a lot of anti seize car had some racing plugs that I've never heard of) thanks for the help!
 

·
Registered
Joined
·
3,097 Posts
Thanks for coming back with the solution.
You're right. It's usually something stupid.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
I would like to try and get some one else to write the tune though I'm not impressed with what I have. I knew it was something simple I just let my brain overload my experience.
 

·
Registered
Joined
·
3,097 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #13
Well I stand corrected on being fixed ran good for one night.... really at a loss here. There's not too many things I have ever not been able to fix. I super charged a 2011 town car but this has me stumped. Might just have to take it to ford i dont know I'm open to some ideas...
 

·
Registered
Joined
·
535 Posts
Well I stand corrected on being fixed ran good for one night.... really at a loss here. There's not too many things I have ever not been able to fix. I super charged a 2011 town car but this has me stumped. Might just have to take it to ford i dont know I'm open to some ideas...
I'd try Power By The Hour or VMP if I was in FLorida...
 
1 - 15 of 15 Posts
Top