Ford Mustang Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
For less than a week I've been the new owner of a previously owned 17'000km Grabber Blue, pony package with 3.31 and a roush axle back. I've never owned a car this new and have been pretty impressed with it so far..

Couple things I'm concerned about tho:

1- Cruising at about 100km/60mph I get a lot of vibration in 6th gear, it's RPM is under 2g is that too slow to be running in 6th with the 3.31? (my dash has been showing 17mpg with a mix of city and highway, clearly I don't know how to drive this for fuel economy yet hah)


2- With the Roush axle back get a lot of "back firing" I've seen video clips and it seems to be pretty common but is it anything to worry about?

3- I've just got the basic stereo, I've always been one for after-market stereo equipment cause it's more current. I didn't even look that closely at how the factory one was laid out till I bought the car.. are there any other options other than buying that $200 cheap looking plate that moves the climate control up and allows a double din at the bottom?

Thanks!
 

·
Registered
Joined
·
1,898 Posts
For less than a week I've been the new owner of a previously owned 17'000km Grabber Blue, pony package with 3.31 and a roush axle back. I've never owned a car this new and have been pretty impressed with it so far..

Couple things I'm concerned about tho:

1- Cruising at about 100km/60mph I get a lot of vibration in 6th gear, it's RPM is under 2g is that too slow to be running in 6th with the 3.31? (my dash has been showing 17mpg with a mix of city and highway, clearly I don't know how to drive this for fuel economy yet hah)


2- With the Roush axle back get a lot of "back firing" I've seen video clips and it seems to be pretty common but is it anything to worry about?

3- I've just got the basic stereo, I've always been one for after-market stereo equipment cause it's more current. I didn't even look that closely at how the factory one was laid out till I bought the car.. are there any other options other than buying that $200 cheap looking plate that moves the climate control up and allows a double din at the bottom?

Thanks!
Congrats on the car. The vibrations your getting are most likely related to the ROUSH setup you have and probably not something with the car. I would say that you should hit the rest button on your MPG thingy and see if it goes up, I've NEVER had as low as 17 on my car.

Enjoy the ride!
 

·
Registered
Joined
·
7,791 Posts
For less than a week I've been the new owner of a previously owned 17'000km Grabber Blue, pony package with 3.31 and a roush axle back. I've never owned a car this new and have been pretty impressed with it so far..

Couple things I'm concerned about tho:

1- Cruising at about 100km/60mph I get a lot of vibration in 6th gear, it's RPM is under 2g is that too slow to be running in 6th with the 3.31? (my dash has been showing 17mpg with a mix of city and highway, clearly I don't know how to drive this for fuel economy yet hah)


2- With the Roush axle back get a lot of "back firing" I've seen video clips and it seems to be pretty common but is it anything to worry about?

3- I've just got the basic stereo, I've always been one for after-market stereo equipment cause it's more current. I didn't even look that closely at how the factory one was laid out till I bought the car.. are there any other options other than buying that $200 cheap looking plate that moves the climate control up and allows a double din at the bottom?

Thanks!
When you bought it did you get the remainder of the warranty transferred to you?

If so then I would take it to the dealer and have them see about the vibration as it shouldn't be doing it. There is a known vibration when slowing down between 3,000 and 2,000 but not when cruising.

The popping you hear from the roush is normal and is not back firing and it would do it even if it had the stock exhaust it just wouldn't be as loud.

Stereo is not going to be a cheap fix. Other than the method you mentioned, you could look for a stock shaker unit taken out of a premium car.
 

·
Registered
Joined
·
112 Posts
i can help with number 1. i have the 3.31 with my performance package and when on the highway unless i have a reason to be going faster i constantly cruise at 60 in 6th and i dont get any type of vibration. when im driving efficiently i usually keep the rpms between 1k-2k. the biggest thing is putting it in nuetral when coming up to a light that is red. the more you have it in nuetral the more effincient you are when rolling because the rpms are so low. thats my 2cents if it helps
:bigthumbsup
 

·
Registered
Joined
·
532 Posts
3- I've just got the basic stereo, I've always been one for after-market stereo equipment cause it's more current. I didn't even look that closely at how the factory one was laid out till I bought the car.. are there any other options other than buying that $200 cheap looking plate that moves the climate control up and allows a double din at the bottom?

Thanks!
I just posted this today...

http://www.allfordmustangs.com/forums/2011-v6-mustang-tech/307796-scosche-dash-kit-2011-v6.html
 

·
Registered
Joined
·
434 Posts
Stereo is not going to be a cheap fix. Other than the method you mentioned, you could look for a stock shaker unit taken out of a premium car.
The shaker stereo is definitely nothing special. If you want better sound, I wouldnt even bother with it.
 

·
Registered
Joined
·
491 Posts
Congrats on the car. The vibrations your getting are most likely related to the ROUSH setup you have and probably not something with the car. I would say that you should hit the rest button on your MPG thingy and see if it goes up, I've NEVER had as low as 17 on my car.

Enjoy the ride!

this would work, but ive read someones post that said the computer actually cuts gas to the engine during engine braking, and that would be more efficient. just passing along hearsay
 

·
Registered
Joined
·
411 Posts
Get rid of the droney roush and put Borla Tourinf, and swap out the factory 5x7s. For about $800 should solve all your problems


For less than a week I've been the new owner of a previously owned 17'000km Grabber Blue, pony package with 3.31 and a roush axle back. I've never owned a car this new and have been pretty impressed with it so far..

Couple things I'm concerned about tho:

1- Cruising at about 100km/60mph I get a lot of vibration in 6th gear, it's RPM is under 2g is that too slow to be running in 6th with the 3.31? (my dash has been showing 17mpg with a mix of city and highway, clearly I don't know how to drive this for fuel economy yet hah)


2- With the Roush axle back get a lot of "back firing" I've seen video clips and it seems to be pretty common but is it anything to worry about?

3- I've just got the basic stereo, I've always been one for after-market stereo equipment cause it's more current. I didn't even look that closely at how the factory one was laid out till I bought the car.. are there any other options other than buying that $200 cheap looking plate that moves the climate control up and allows a double din at the bottom?

Thanks!
 

·
Registered
Joined
·
491 Posts
Get rid of the droney roush and put Borla Tourinf, and swap out the factory 5x7s. For about $800 should solve all your problems

hes got the base, not the shaker. the 5x7's will sound worlds better but put an amp in there too. thats my plan
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
Yeah it was calculating 17mpg during the "test drive" miles. So far I've gotten 23mpg at best but I'll be honest I tend to have the tach between 4 & 6g lol. I"ll have to remember the drop it into 6 and relax next highway cruise. And yeah, I'm pretty sure staying in gear on decell does shut down the injectors until a certain rpm.

The vibration or drone probably is the roush.. I don't know I'd this exhaust is for me the grabber blue gets enough attention.. Including from law enforcement..

For now I'm going to add a subwoofer and maybe a componet set while I wait for that new dash plate, cool to see there might be new options.

Thanks a lot guys
 

·
Registered
Joined
·
1,319 Posts
Total noob question, but in the '05-'09 model, it used to say "Shaker500" on the radio. Now, if you have a shaker 500 it just says "Shaker" correct? So I'm assuming if you have a base model, it won't say anything?
 

·
Registered
Joined
·
491 Posts
Total noob question, but in the '05-'09 model, it used to say "Shaker500" on the radio. Now, if you have a shaker 500 it just says "Shaker" correct? So I'm assuming if you have a base model, it won't say anything?


yea my base model doesnt have any writing on it
 

·
Registered
Joined
·
1,319 Posts
Yuck, I can only image what the base stereo sounds like. The shaker500 leaves more than a little to be desired. The Boston Acoustic system in my bro-in-laws Camaro blows the Shaker500 away...
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #15 ·
Yeah... the base stereo does kinda suck. But for now I'm just going to add the sub and the next thing will be to upgrade the speakers and run them with the factory head unit until (hopefully) that Scosche unit is available.

Does anyone know if the factory head unit has an external amplifier?

My sub amp doesn't have speaker level inputs so I'm going to have to get a line-level converter to hook up to the back speakers unless there is a low level output directly from the factory unit. I couldn't find the radio in the factory manual wiring diagrams that are online.

thanks again

also btw I cruised into work today nice and easy and got 29mpg average :bigthumbsup (maybe not a world record but beats my 5.4L Fx4)
 

·
Registered
Joined
·
491 Posts
Yeah... the base stereo does kinda suck. But for now I'm just going to add the sub and the next thing will be to upgrade the speakers and run them with the factory head unit until (hopefully) that Scosche unit is available.

Does anyone know if the factory head unit has an external amplifier?

My sub amp doesn't have speaker level inputs so I'm going to have to get a line-level converter to hook up to the back speakers unless there is a low level output directly from the factory unit. I couldn't find the radio in the factory manual wiring diagrams that are online.

thanks again

also btw I cruised into work today nice and easy and got 29mpg average :bigthumbsup (maybe not a world record but beats my 5.4L Fx4)

i dont know for sure bc i only have the base v6, but i think the shaker has an amp under the dash by the door on the drivers side. let us know
 
1 - 16 of 16 Posts
Top