Ford Mustang Forum banner
Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
So my cooling fan stopped running one day and i tested the motor and it was just fine, then i opened up my CCRM and a Resistor was burnt up, went to a junk yard and found a new CCRM in mint condition and it fixed the fan problem but i still have 5 check engine errors

223-?
224- Erratic IDM input to processor
332- Insufficient EGR flow detected
452- Insufficient input from Vehicle speed sensor
543- Fuel Pump secondary circuit failure: Battery to PCM

If you have any suggestion on how to fix these please post i have already attempted to take off my EGR but mines an electric one and it doesn't look like any of the EGR's that people on youtube have videos cleaning.

Another thing i have noticed is that my RPM needle is only reading half of my RPM's so it shifts at 2k instead of 4k that it once did.

Please give input and thanks in advance for the info.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
the ccrm is also called constant control relay module, it is located under the hood on the passenger side of the car and is a little black box thats for the 90-93 4 cyl models other modles may be in the same place or they can be inside the finder well just follow your wires. The CCRM is also riveted so be careful while drilling the rivets out or you'll crack the chip. If that doesnt help tell me and ill try to claer it up a little more or give you a new thought on how to get your fan running
 

·
Boss Member
Joined
·
4,627 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
yeah that really didnt help cause i already had all the info and its posted as well, i just need peoples thoughts on how to replace things and get the lights to go off
 

·
Boss Member
Joined
·
4,627 Posts
Wish I could help. Not real up on the 3 digit codes.
I going to try. So if wrong easy on me. Here is link.
3-Digit Codes
223 Dual ,spout or IDM circuit fault. Ignition system.
332 EGR. I would say take apart and clean.
452 Vehicle speed sensor. It at the trans in Speedometer cable. May want to check wiring at that point and test or replace. Is cruise control dead also? Pretty sure that is what it read also.
543 Fuel pump monitor circuit no power.
May try here and punch in car info and try.
ChiltonLibrary.com - Authorization Error
Best I could do. Will to try more if this does not help. Maurice
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
ok yeah thats alot more helpful, see my problem with taking the EGR off and cleaning is that mine seems unlike other that ive seen on youtube my just detaches from the electric plug and the housing of the egr but then it goes directly into a staright pipe which everyone elses seems to come right off the block or where ever its mounted IDK?

and for the speed sensor yes my cruise control is out and always has been since i bought the car about i guess 2 yrs now ut ive never had a check engine light on for it so i guess ill check out that cable.
so i guess it would be good to change out my ignition coils to maybe get the rpms to read correctly
 

·
Boss Member
Joined
·
4,627 Posts
On the dual plug engine. I can't remember with the half tach deal. Either a coil pack out or ignition module on intake. Sorry don't remember but if do or find will repost. Maurice
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
ok well i got my egr off and kinda cleaned it im going to take it off again today and do more cleaning and i have replaced my 02 sensor and now all my check engine light are off....some of the light may have been stored stuff so im going up to oreillys to have them reset the system and check and that way if it comes back on again i can check one place and turn it off.

i was driving today and my cars rpms jumped up to normal and a half mile down the road they went back down so im going to disconnect the cable and blow them out.

The great thing is, is that my car shifts so much smoother now and it doesnt throw me back midshift:kooky:YAY

thanks maurice youve been alot of help, ill post more here if issues reoccur
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top