Ford Mustang Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
Hey guys, my 5.0 has been sitting for a year and recently tried to fire it up last weekend, problem is i'm getting fuel just no fire through the distributor.

I've read up on the "crank but no start" thread and tried everything possible i can think of.

So no I'm out of idea's :headscratch:
 

·
Registered
Joined
·
5,633 Posts
Most likely something is sour in the distributor. Check for fire at the plugs, then track back.
 

·
Registered
Joined
·
5,633 Posts
Just changed the coil cept still no fire at the plugs nor the coil:scratchchin
Distributor, next stop. Might be the DI module (pricey part) - what model year is this 5.0?
 

·
Registered
Joined
·
155 Posts
Discussion Starter #6
1990
thing is, i had it fired up a couple of weeks ago for about 5 mins, then turned out i was taking my truck, so shut her off when i put it in the garage, now, nothing...
 

·
Registered
Joined
·
46,020 Posts
It could be the pickup, or what's called the Hall Effect sensor. Does the tach jump up and down when you're trying to start it?
 

·
Registered
Joined
·
5,170 Posts
Pick up or TFI gets my vote.

you can take the TFI to a parts store and have them test it for free. The Pick -up Coil( or Hall Effect sensor as Eagle refers it) is another story. You can test it, but requires dismanteling the dizzy to acess it. If you want the Test Let me know.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #9
when i crank, no..tach does not jump up...does nothing actually ahaha..
I'll try to take that part to get it tested, then i'll see if i can't get (89coupe) to give me the "test"
 

·
Registered
Joined
·
1,520 Posts
If you have a buddy with an alike car, just do the dizzy swap to see if yours starts with his dizzy.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #11
I was farting around to see what the problem could be for it not to fire, and found it..

I turned the crank by hand and turns out the rotor inside the distributor isn't turning at all, any inputs?
am i fubared with the cam?
 

·
Registered
Joined
·
5,170 Posts
I was farting around to see what the problem could be for it not to fire, and found it..

I turned the crank by hand and turns out the rotor inside the distributor isn't turning at all, any inputs?
am i fubared with the cam?
Pull the dizzy out, sounds like you have sheared the roll pin on the shaft. Becareful and try not to drop the gear in the motor.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top