Ford Mustang Forum banner

No Power to radio after install.

10273 Views 5 Replies 3 Participants Last post by  Litton500
Hello everyone,

Hoping someone can help me figure out what's wrong.

I was replacing the factory skipper 500 radio HU with a Kenwood ddx419 in my 06' Mustang. I hooked up the new unit earlier today to test it out and it was working fine I played a cd and connected my Iphone. After testing, I disconnected everything I went inside to solder the harness together & heat shrink. Finished that came back out hooked everything back up and there was no power to the radio at all now. So I went back and cut and re-twisted the Ignition and constant power wires thinking I messed up the metra harness. Same thing, Then I thought I might of blown up my new HU, so I hooked up the shaker 500 and there was no power.

I used a test light to check if my radio fuse (#20 radio - start) was "bad" -It checked good. So I replaced it to be sure - no luck.

I then pulled all other fuses in the car (w/ battery disconnected) none were blown.

I disconnected the battery & tried to start and let the car fully discharge and tried again. -nothing

I then thought may I broke a wire pulling the harness off, I felt for lose wires in the car's harness and felt for any "lumps" in the wire. -nothing

My dad was generous enough to loan me his Explorer - Both units power up.

Everything else seems to work okay. I can still drive the car and everything else functions except the radio.

Thank you in advance for any help.
See less See more
1 - 6 of 6 Posts
Maybe you shorted out the radio somehow. With everything connected I'd use a multimeter lead that can pierce the wires and check for power going directly into the radio and continuity to ground.
This is probably a stupid question, but did you make sure it was grounded? When I installed mine, it came loose and didn't work.
I installed the ground by drilling a small hole at the base of the firewall then running a screw through the hole and a ring terminal attached to the ground.

Even if this was a bad ground, the factory unit should have worked without issue. - I would think.

Is there a possible in-line fuse along the factory harness that could be blown?
See less See more
My dad was generous enough to loan me his Explorer - Both units power up.
If both units power up in your dad's Explorer then you need to find out what you lost in your vehicle. Pretty sure either 12V or ground are missing or you're grounded somewhere you shouldn't be. Just because you drilled a hole doesn't mean you have a strong ground. Check your ground to a hot wire and you should get at least 12V, if not the ground is not a good one.
See less See more

Turned out to be a fuse after all. After taking a multimeter to the harness and finding no power, replacing the radio and ignition fuses in the car. I then got the Haynes manual out and found a diagram that listed every fuse. It was #56 under the hood, I didn't see it listed in the owner's manual, it's a mini fuse. I thought the only fuses under the hood were for the Shaker 1000 setup (if the car came with it).

Also I made a better ground for the car so this doesn't happen again.

Many Thanks to smittyrock and chertelendy!
See less See more
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.