Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
This is a repost to one of my other threads a while back but last time I didn't have the DTCs. I wanna say that I still don't have any problems with the car other than the idle varies from about 600rpm to 900rpm when the light flashes(it had done it since this started). I just took off my tune because I read that hard upshifts could possibly cause this and I don't wanna risk it. My main concern is that I am about to do a trade in for a 00-04 GT(Manual of course) and I don't think a dealer is going to take it with the light blinking but to me it sounds like a clutch solenoid which is $40 or a sensor. The dealer will probably think it will need a tranny rebuild but anyway here are the DTCs give me your opinions on what you think.
DTCs:
P0741: Torque converter clutch colenoid ckt perm. or stuck off
P1744: Torque converter clutch solenoid ckt performance
P1740: Torque converter clutch solenoid inductive signature
I don't have any slipping whatsoever, like I said before the only problem I have is the idling problem.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #2
Just took the car out for a test drive with no tune and it drives like it just came out the show room but after about 2 minutes of driving the O/D off light started flashing. When it happened I was cruising at 55mph and no slipping or any kinda troubles at all so im lost here.
 

·
Registered
Joined
·
6,859 Posts
For starters, confirm fuse F2.17, F2.28, and F2.35.

http://www.allfordmustangs.com/foru...r-swap-wont-fire-please-help.html#post2669271

Seems likely to me that there's a problem in the torque converter lock-up. This would explain why it happens during steady crusing.

The idle problems could also be lock up torque converted related. IE not releasing as it should and bogging down the motor.

What is the condition of the transmission fluid?
 
1 - 3 of 3 Posts
Top