Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
alright boys, aside from a couple little leaks i know about. such as the rear main and just seals really... she's burning some oil too.. I think she needs some new rings for the engine has 260 000 KM's on it.. and a bunch of those years its been drivin by a young kid, so she's probably been bagged on a bit.. Anywho.. Anytime i leave the car on a slight up hill grade and she keeps running, she loads up and when i take off... pffffff... leaves a honda sized cloud behind... What im thinking it is a lifter's stickin' cause i think there is one anyways.. she ticks pretty good when she's full of oil.. put some lucas oil additive thinkin' it might lube it up a bit better.. did slightly, just got quieter..
so i think its either slippin' past my valves and gettin' in there for some reason, or its slippin' past the rings.. but it doesn't smoke all the time, thats the thing.. just facing up hill and idling for a couple minutes.. you can smell it.
any thoughts??
91' mustang... home made cold air, EGR plate (thats another thing, could it be the plate i built is bungin' up?) Still, shouldn't be burnin' that much oil anyways.. ported the upper manifold for casting marks and **** and thats about it!

I realize the motor is pretty old.. and i will be putting a new one in, just curious to why it is loading up, when im facing up hill
 

·
Registered
Joined
·
3,900 Posts
Sounds like Stem seals. Or the return holes may be blocked in the rear of the HEAD and the oil is pooling in the rear valve stem area and sucking it in.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
yea thats what i thought it was as well, seems pretty straight forward... alright! thanks for the input tom, just wanted another opinion.. :bigthumbsup
 
1 - 3 of 3 Posts
Top