Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
Just installed a new autometer oil pressure gauge, and its reading 59psi. Have talked to some people and they have told me that about 20 is normal idel and 40 to 50 highway. What do you all think??
 

·
Registered
Joined
·
3,104 Posts
Ford Small Blocks do not need much oil pressure to run reliably, but the 20 to 50 or so sounds about right.

What does your gauge say at idle?
 

·
Registered
Joined
·
70 Posts
Discussion Starter #3
59psi. at idle. I am using a pretty heavy weight oil could that cause a greater pressure?
 

·
Registered
Joined
·
3,104 Posts
All a heavy weight oil does is increase wear at startup. :eyepoppin

It also robs you of some horsepower as does a high pressure or high volume pump. 59PSI sounds high even for a high pressure oil pump.

Is the gauge mechanical or electrical? If it's electrical, you may have used sealant on the threads. That might be insulating the sending unit from ground which is the block via the threads on the sending unit. That might result in a higher reading than actual. :?:
 

·
Registered
Joined
·
70 Posts
Discussion Starter #5
Its a mechincal gauge.
 

·
Registered
Joined
·
897 Posts
dude;59 is fine at startup,as she warms up the pressure will go down.im sure it doesnt idle at 59 after its hot.on the highway its anywhere from 50-55 when its hot.depending on the engine wear and obviously the bearing wear.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top