Ford Mustang Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi Guys,

My '06 V6 Mustang came off warranty a month ago. And like you'd expect, the check engine light came on abt 2 weeks ago after I filled gas. I hadn't tightened the gas gap, which I then did. The engine light never went off.

I took it to the dealership this weekend and they said it's code P0456 and that I would need a new fuel pump and a fuel in-line. Something about a new bulletin from Ford about a malfunctioning transducer in my fuel in line. (not sure why i have to change the fuel pump if the transducer in the in-line is bad). Total cost $800. They also said that it doesn't do any damage to my car but I won't pass my emissions check.

Then I went to autozone and they said that either the code just didn't get reset or I need a new gas cap. So I disconnected my battery yesterday. When I connected it back, the engine light was off and has stayed off till now (driven abt 30 miles).

My emissions check is due this week. And that's really my concern for now (unless someone tells me this does damage to my car).

my questions:
1) How do I know for sure if it's the fuel pump/in line and not just the gas cap?
2) How long after i reset the code do i have to drive to get my emissions test (I'm in Texas if that matters)
3) If the light stays off when I go to the emissions check, is there any reason for them to fail me? (from reading any past codes on the OBD)


Thanks!!
 

·
Registered
Joined
·
40 Posts
Never try and erase codes by disconnecting your battery and erasing your KAM.. The light obviously came on for a reason...Dont quote me but I believe that any code in the P0400's is an EVAP code...I would get a second opinion
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top