Ford Mustang Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
341 Posts
Discussion Starter #1
Driving home, my car started bucking slightly. It is very hot so I didn't think much of it as I had the A/C on. Up comes a CEL P 430 I think. It was a cam positioning sensor. I cleared it with my SCT and it didn't come back on yet. I cleared the code but, I know that won't fix the issue. My question is now that the car is running fine, was it a temporary glitch or is the sensor affecting the normal operation of the car ?

Thanks in advance for the responses. I don't want to do damage to the car on my way home.
 

·
Registered
Joined
·
341 Posts
Discussion Starter #2
No responses ? That's okay. The CEL went on again on the way home. Can anyone tell me where the P340 sensor is located ? I have an extended warranty that costs me $125 per problem & I need to know if I can do this myself. Please help.
 

·
Registered
Joined
·
766 Posts
I have the same problem on my 05. Im searching the forum for information. Thats how I found your thread. The last time I looked I think someone said the first thing to do is to check the alternator. Somehow that affects that code. I also get the bucking under throttle, especially after a long run on the highway. Very intermittant and I have never had that happen on the track whan I play, so I dont worry about it. Gary
 

·
Registered
Joined
·
341 Posts
Discussion Starter #4
I checked on the web for this problem as no one has been able to help me. The other sites state that I need to replace the alternator. Question: I am out of factory warranty but, I have the extended warranty. Will the TSB that is out for this car be valid ? It is an '06 Gt.
 

·
Registered
Joined
·
341 Posts
Discussion Starter #5
Gary, Thanks for responding. What about my extended warranty question? $125.00 is better than $400.00 if I do it myself.

Thanks a ton for responding. Pat
 

·
Registered
Joined
·
341 Posts
Discussion Starter #6
Talked to a knowledgeable friend and he believes if a TSB is out , the parts & labor should be covered. The Moss/magnussen (?) act states that any mods have to be proven to not cover this problem. I have only CAI and tune. This dealer I go to has never had a problem with my mild mods. Let's hope the pattern continues. The alternator is the likely culprit.
 

·
Registered
Joined
·
341 Posts
Discussion Starter #7
Autozone Re-manufactured alternator = $179.00 . We'll see if TSB covers me first, Ext. warranty 2nd.
 

·
Registered
Joined
·
766 Posts
Try to find an automotive electric shop in your area. they usually can rebuild an alternate for a lot less than buying one from the retailers.
 

·
Registered
Joined
·
341 Posts
Discussion Starter #9
Going to my dealer to see if the TSB will cover it first. I have the ext. warranty but, that cost me $125. per.
 
1 - 9 of 9 Posts
Top