Ford Mustang Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

Registered
Joined
10 Posts
Discussion Starter · #1 ·
Okay, I recently installed 1" aluminum psacers on all 4 of my tires, everything was fine for the first few days but now when i break there is a very slight creaking noise coming from the front end. it makes no odd noises when i drive or any thing else and dosn't do it all the time. Any Ideas / Similar eexperiances. taking it by the dealer as soon as i leave work today to have them look at it.
 

Registered
Joined
3,133 Posts
As for solution, take spacers off, it noise goes away, then you know its being caused by the spacers. I'm curious, why did you add them in the 1st place :?:
 

Registered
Joined
1,621 Posts
I've heard of spacers being not recommended due to causing wheel stud failures.

Stuff could be shifting around with the spacers. There's a lot of force when braking.
 

Registered
Joined
10 Posts
Discussion Starter · #4 ·
Thats it

Yeah its the spacers not gripping where it should be. As far as why, i wanted the look, but Now I can see why a lot of people don't use them. So gonna take em off and no worry about it. Thanks for the quick response guys. appreciate it as usual.
 

Registered
Joined
12,325 Posts
glad you got them off before anything happened. I've yet to hear any good things about them, just issues
 

Registered
Joined
10 Posts
Discussion Starter · #6 ·
Yeah just got em off about an hour ago, good lord and impact wrench and a hydraulic jack make things way easier. Had no damage to the car or the Spacers from what i can tell, now the hard part is gonna be trying to get my money back on em. But oh well if i can't its just a moderately expensive lesson in the diy arena.




New pics of the new paint job coming soon.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top