Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
727 Posts
Discussion Starter · #1 ·
Hi,

Just wanted to see if anybody has had any problems after installing fog lamps or aftermarket hid lamps on their cars.

My car started having this weird problem where the headlamps and turn signals would turn on on their own and then turn off.

My car has been to the dealer 3 times (now its the third time) after the problem has evolved into now having the abs, airbags, ESP lights going on besides the headlamps flickering.

Turns out that today I saw an earlier model (mine is a 2010 V6 auto) that had aftermarket HIDs installed, presenting the exact same failure as my car. The headlamps and turning lamps turning on an off themselves, with the car shut down and closed.

Anybody else having these problems? I installed the Starkey Products Fog Lamps for my 2010.
 

·
Registered
Joined
·
147 Posts
i cant specificly say that i have had this problem before but my buddy who bought cheap HIDs had loads of problems with his car after install if he set his cruise control with his foglights off then turned them on his car would have like a power surge almost shuting off and imediatly back on.
 

·
Registered
Joined
·
727 Posts
Discussion Starter · #3 ·
I got back the car finally... they replaced the module that controls all the lights, sensors and remote access. They even re-wired the fog lamps and connected them directly instead of with the harness that came with them. And all under warranty...

Hope this is the end of the problem. Aside from that the car has been 100% trouble-free so hopefully it will stay that way
 
1 - 3 of 3 Posts
Top