Ford Mustang Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
432 Posts
Discussion Starter #1
OK, this isn't the biggest issue in the Mustang world but I am still pondering it this morning. I was out doing a little top-down cruising last evening in my one-month old Mustang and noticed something I have never seen before. This pertains to the radio display area that sits in the top of the center stack. I think I never saw it before as you could only see it when the sun was directly behind the car and shining on the display area in question. Am guessing you could reproduce this with a strong flashlight though...

On the left side of the display, directly over the Compass direction thingy, there appear to be un-lit symbols for the HVAC indicators including a little fan-speed symbol?

On the right side of the display, directly over the Ext Temp indicator, there appears to be un-lit symbols for another range of temperatures, etc.

To my knowledge none of these symbols have ever been lit up - has anyone else ever noticed this before? At least in my car only the direction indicator and the Ext Temp value show up. Just curious...
 

·
Registered
Joined
·
71 Posts
Symbols

Automatic Climate control option displays? Maybe?
 

·
Registered
Joined
·
432 Posts
Discussion Starter #3
Automatic Climate control option displays? Maybe?
Well, I thought so too, but - doesn't the Auto Climate Control thing only come with the Electronics Package, which uses the large LCD screen? Which means that the display screen the rest of us have wouldn't be part of those cars so equipped?
 

·
Registered
Joined
·
45 Posts
This display is used in other Ford products too. My wife's Mariner has this exact display and the fan speed indicator is used. I wish it was in our car as well, the viewing angle to the fan speed knob is less than ideal. Also, she has dual-zone climate controls but no NAV system, so the other temp indicator gets used as well. It's an example of parts sharing, but I don't mind since the audio display ends up being the same in both of our cars.
 

·
Registered
Joined
·
125 Posts
I know for a fact they are functional in our mustangs. I have once accidently actavated it and i have no idea how.
What happens is the two fans on both sides of the display start spinning and all of my fan vents started running then turned off again. I was at the time just trying to turn on my fan but didnt know how as i just bought the car. I accidentley hit two buttons at the same time because i was driving at the time and it happend. Havent been able to reproduce it ever sence.

edit, oh yeah while the fans were running thouse extra temp numbers were also on. At first i thought it was engine temp.
 

·
Registered
Joined
·
124 Posts
Through some weird button pushing I have had those symbols light up. The fan goes super fast and there are 2 fan symbols on each side and they say 88 degrees. Of course, nothing works. I've had it happen twice.
 

·
Registered
Joined
·
22 Posts
I have watched videos on youtube on this. by hitting the power button and the button below or above the power button at the same time will do what you are talking about.. push both at same time. its like it goes through a diagnostic test.
 
1 - 9 of 9 Posts
Top