Ford Mustang Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have what should be a simple problem. My right turn signal will not blink. I know I checked the bulbds in both front and back and it still will not work. Running light work great, it just the turn signal.

I Called Dallas Mustang they told me I have bad bulbs as if the signal unit had gone bad it would affect the left blinker also.

Anybody have any good ideas.?
 

·
Registered
Joined
·
9,198 Posts
Hello. :) It isn't necessarily true that a turn signal switch problem would affect both sides. Is it both the front and back that don't work, or, just the front? :)
 

·
Registered
Joined
·
2,624 Posts
I've had this problem. Try wiggling the rubber boot that attaches the wiring to the taillight. Mine used to do this all the time. My left turn signal would work unless I stepped on the brake or turned on the running or headlights. Now my taillight harness is totally trashed and I'm waiting on my new one to arrive.
 

·
Registered
Joined
·
4,555 Posts
I would remove the rear lens and covers, on the rear the turn signals and brake lights are the thicker filament, the thinner filament is for the tail lights, and observe that the proper filament is lit, a corroded ground or socket can cause resistance, and as such not enough current flows to make the 552 flasher flash. I doubt if the turn signal switch is at fault, even its age, 99.9 times its the bulbs or the contacts or connections in the socket, put on a glove and wiggle the bulbs. The fronts could have the same problem, causing it not to flash. They use the thicker filament for the turn signal and the thinner one for the park lights, which I believe are only on when you have the park lights on (depending on the year). A little sandpaper wrapped around a pencil or dowel rod can clean up the socket. Good Luck.
 

·
Registered
Joined
·
174 Posts
I have what should be a simple problem. My right turn signal will not blink. I know I checked the bulbds in both front and back and it still will not work. Running light work great, it just the turn signal.

I Called Dallas Mustang they told me I have bad bulbs as if the signal unit had gone bad it would affect the left blinker also.

Anybody have any good ideas.?
When you say that they will not blink, do you mean that they are constantly on? Or are they always off?

If they are on, but the light isn't very bright, then it could be as simple as a poor ground, or what's called a high impedance ground, where everything seems fine (when measuring with a meter) until you try to pull some current through the circuit. This happens all the time with these old wiring harnesses.

Do as 66Sprint200 suggested and try to wiggle the wires at the connectors both at the front and back, as many times this will temporarily create a better ground connection.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top