Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
can anyone give me some advise on how to get rid of my rough idle situation. when the car is cold it idles fine but 2mins later it starts with the idle jumping, almost seems like its going to shut off , i just replaced the fuel pump, and filter cuz it was shuting off when the car got hot, i cleaned the iac i think its called , with carb cleaner and checked the tps . any other suggestions??
plus changed my plugs , oil , and cleaned k&n filter and inspectioned wires.
 

·
Registered
Joined
·
2,975 Posts
re check to make sure you have the wires goin to the right cylinders. did you check the voltage of your tps at closed? check it again with the key on engine off and open the throttle to full range and make sure there are no fluctuations in the full range of motion.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
i checked my wires there in the correct place as for the tps its at .98 but what what do u mean but wide open throttle it should move, or shouldn;t move at all , or it should but not much???? if so how much it should move, up or down?? thanx
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
WOT the tps reading is at .475 closed , is .980 is all that correct????

the care still misses when it is up in a higher RPM whne i'm on the gas
not a clue what it could be???
 

·
Registered
Joined
·
4,807 Posts
It should be at about 4.30-4.9v at WOT
 

·
Registered
Joined
·
11 Posts
Look for irratic reading when you open throttle slowly.If DSO is available you can look at the analog curve and should not fluctuate, curve should be smooth.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top