Ford Mustang Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
The guy I bought my car from said that its just the factory welds showing through because of its age. I tend to disagree with this statement, and believe its from abuse/hard wear & tear, in other words, I think he beat the SH*T outta this car. Who is right? What should i do to fix this? Maybe a recomendation on a good body filler for this job? Will full frame connectors keep this problem from happening again in the future? Any help is greatly appreciated.
 

·
Registered
Joined
·
61 Posts
They will in time tend to rust in that area. It is filled with lead from the factory. There is two to three plug welds there and one or two stich welds from the factory. Beating on a car may cause stress cracks that will intern let moisture through and cause some rust. If there are no cracks it wouldn't suggest the car has been beat. But remember its a 5.0 they almost all have had the crap kicked out of them since the day they rolled off the line.
 

·
Registered
Joined
·
530 Posts
85GT 5.0 said:
I tend to disagree with this statement, and believe its from abuse/hard wear & tear, in other words, I think he beat the SH*T outta this car.
Jeeez, and here I always thought thats what the hell they were made for. I've beat the ever living $hit out of mine for 13 years, not to mention what the psycho that owned it before me did to it for 8 years, and I don't have any rust there, go figure.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top