Ford Mustang Forum banner
Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
This past weekend I decided to remove my Tunable Inductions cold air intake, as well as my Zex nitrous kit to get ready for a procharger install on my 2006 Mustang GT.

After tuning the car back to the stock tune (so the tuner can be sold) with my handheld SCT XCal2 tuner I've had several problems regarding my computer system:

-Speedometer Doesn't Work
-Tachometer Doesn't Work
-Odometer Doesn't Work
-TCS Doesn't Work
-A/C Compressor won't engage, A/C isn't cold (which is important here in TX)

These are just a few of the issues which also include my check engine light, battery light, etc. being lit.

Previously to tuning it back to stock, the car threw no codes and had no problems.

Here's the kicker: the car drives absolutely perfect. It drives like it's brand spanking new, no hiccups, no limping, no bogging etc.

Even at wide open throttle there are no issues.

I've tried unplugging the battery overnight to reset the computer but it didn't work... however it still has my presets saved in my radio so maybe it still hasn't reset.

Any ideas, suggestions, or help would be much appreciated.

Sorry this post was so long, but I really need help!
 

·
Premium Member
Joined
·
72,878 Posts
Have you ever had any issues with water leaking on the passenger side? Sounds to me like the Smart Junction Box may be toast.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Have you ever had any issues with water leaking on the passenger side? Sounds to me like the Smart Junction Box may be toast.
No, I've never had any water leaking issues. Why would the smart junction box be toast from tuning to stock? I really think something just went wrong as it was tuning... but I'm not really sure what to do to fix it.

I'll do a little research on the smart junction box.
 

·
Premium Member
Joined
·
72,878 Posts
No, I've never had any water leaking issues. Why would the smart junction box be toast from tuning to stock? I really think something just went wrong as it was tuning... but I'm not really sure what to do to fix it.

I'll do a little research on the smart junction box.
The SJB failing could just be a coincidence. Dash lights/gauges failing is usually an indicator of an SJB problem. Did you try reflashing the tune again?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
The SJB failing could just be a coincidence. Dash lights/gauges failing is usually an indicator of an SJB problem. Did you try reflashing the tune again?
Hmm...

Yeah I tried reflashing, the computer ignores the tuner.

When it gets to the part where it says "Turn the Key Over DO NOT START" it just stops there. I turn the key over and it won't respond. Normally after turning the key over it would ask me to press select. I waited on it a while and it finally timed out.
 

·
Registered
Joined
·
10,876 Posts
I would just take it to a stealership and have them re-flash the computer. your going to go with the procharger so :scratchchin
 

·
Registered
Joined
·
1,650 Posts
Have you ever had any issues with water leaking on the passenger side? Sounds to me like the Smart Junction Box may be toast.
Dont get me started!!!
Seriously, OP put your hand up in the passenger side kick panel and feel around the SJB and see if it is wet. If its wet its probably shot. My SJB only had a little water on it and it was shot.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
I would just take it to a stealership and have them re-flash the computer. your going to go with the procharger so :scratchchin
Took it to a Ford Dealership the day after it happened and they re-flashed it, didn't do ANY THING. Car was exactly the same when I got it back. I argued with them but they wouldn't let me have the car back until I paid them $100 for absolutely nothing.



Anyways, just got off the phone with my tuner, he says that it sounds like an electronics issue not a computer issue.

Guess you guys were on the right track with the SJB/Electrical suggestions.

He told me to back track all the places I had wiring going for the nitrous kit, and make sure I didn't forget to reattach any grounds, or that something isn't shorting out etc.

So I'll be checking the engine bay and pulling my console tonight to make sure my wiring is still correct, although I have a good feeling he's right and I'm going to find something I missed.

Sure hope so, can't wait to get the car fixed, it's been a stressful weekend. Luckily I've got good friends willing to help me out with these kinds of things.

I'll post up what I find out later tonight. Thanks for all your help! :bigthumbsup
 

·
Registered
Joined
·
781 Posts
Dont get me started!!!
Seriously, OP put your hand up in the passenger side kick panel and feel around the SJB and see if it is wet. If its wet its probably shot. My SJB only had a little water on it and it was shot.
Lets pray its not the same thing u went through :frustrated:
 

·
Registered
Joined
·
10,876 Posts
Well now that Ford reflashed it your tuners is no good unless you pull the strat code and give it to your tuner.
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top