Ford Mustang Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I installed a Saleen Supercharger on my 05 Mustang GT and got a SCT Xcal II tune over the internet. The car runs awsome when cold but once it warms up it seems like it is starving for gas or something like that. I have 39# injectors and a diablo Mafia installed. I have tried adding fuel using the extreme tune program but it doesn't seem to make any real difference. Anybody have any ideas? I tried increasing the timing a little but would get a slight ping at higher rpm's so I put it back. Also the supercharger has a bypass valve on it with an adjustment screw, how do I check the adjustment to make sure it is correct.

Any info would be appreciated,
Mark
 

·
Registered
Joined
·
708 Posts
One would think you're playing with fire trying to make those adjustments with out a propper sensor setup.

Not a saleen product owner myself but isn't the bypass active only at low RPM and preset @ the factory?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
The bypass works all the time it is vacuum operated so when your just cruising it is in bypass. It only applies boost if you get into it. It is set by factory but you have to remove the set screw to install the supercharger so I tryed to make sure the adjuster was in the correct position. I am being very cautious in my adjustments and am monitoring short and long term trims and knock sensors. I have an appointment to do dyno runs but that is two weeks away and this is my daily driver. I was hoping somebody could point me in the right direction of what to check. It runs great just not as good as when it is cold. It goes like a raped ape when cold but once up to temp the response is not the same it is hard to explain it just doesn't seem to accelerate as well once warm. This may be normal.

Thanks,
Mark
 

·
Registered
Joined
·
172 Posts
Mark, have you talked to Andre about this?

I'm hoping to get my car tuned (final tune) this coming week...
 
1 - 5 of 5 Posts
Top