Ford Mustang Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I took off my Sequential Tail Lights on my 05, GT, in hopes of putting them on my new 07 Shelby GT500. When I got down to the back of the bulb where your supposed to plug in the wire to the back of the bulb, I find that whole area is sealed off with what appears to be some very hard plastic, or glue.

Has anyone run into this situation, and if so, what did you do to remove the hardened plastic? Any and all help would be great. Thanks.
 

·
Registered
Joined
·
13 Posts
I have never heard of this problem before, maybe if you posted a picture of the area you are talking about, we can get a better understanding of your problem. Also, I was told that when I bought my sequential tail lights that the wiring for the 05-06 mustangs are different than the 07-08 mustangs, might be something to check into.
 

·
Registered
Joined
·
12,664 Posts
i know that gary paul just installed sequentials on his 2008 gt500. He would probably be the best guy to ask about anything. i know he told me the biggest issue he ran into has his shakker 1000 box in the trunk and having to remove it, but other than that i believe it went smoothly.
 

·
Registered
Joined
·
12,664 Posts
so is that the OEM one or the sequentials?
 

·
Registered
Joined
·
41,825 Posts
White Angel just put a set in herself she may be help you also.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top