Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all! I'm new to this forum and would like some of your wisdom. I have a 2001 3.8l 5spd.

I recently had it in the shop due to a loss of power and one of my cylinders going dead in heavy rain. The day this happened I was driving in the rain and I can tell I'm dragging a cylinder. Not a new problem to me, sooner or later the car dries out and it runs better. So it dries out and the engine is running like normal. Then a little while later there is this sort of "pop" and my power and acceleration just go to pot.

I took it to the mechanic and he changed the plugs, wires, and distributor coil pack thing. He recommended changing the o2 sensors and the maf to help with the power loss but at the time I couldn’t afford it.

Well I've since changed both of the upstream o2 sensors and the maf but to no avail. I still have very little power and terrible acceleration and it's accompanied by a constant yet sporadic ticking sound and really terrible smelling exhaust.

The CEL is still on for one of the upstream o2 sensors and every so often it flashes indicating a misfire. I work as a driver for Domino’s so I need my car, not to mention I don’t like it why my baby is sick…
 

·
Registered
Joined
·
267 Posts
Sounds like it got hydrolocked during the heavy rain somehow and may have caused some damage to the cynlinder parts making it missfire. it could have a bent rod or valves if hydrolocking did occur.
 

·
Registered
Joined
·
267 Posts
You would probably have to get a professional mechanic to take a look at it. Might cost you some $$$ though.
Also you could run a compression test to see if its losing compression...
 

·
Registered
Joined
·
6,859 Posts
Try performing a compression test.

Always post the full DTC code(s). There are 1000's and they each have a story to tell.

Check the routing of the spark plug wires. Are they touching any metal parts? Have the factory stand offs and looms been used?

Try this old racer's trick. Run the car in a totally dark location. Look for the blue hue of escaping spark. Inspect the plug wires for white spots which will be evidence of arcing.

Are there any exhaust leaks? Any vacuum leaks?

Does the car use oil or coolant?
 

·
Registered
Joined
·
9 Posts
I have a 2001 v6 mustang and my car has been acting the same way, and on the way to work this morning I finally heard a pop. To me it seems as if I need to change my plugs but I hope that's all it is. My check engine light has not come on so there is no way of getting any codes. When you figure out what the problem is let me know please cause everything your car is doing is exactly what mine is doing. Best of luck to u!


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
992 Posts
Have the converters checked. One or more of them might be cloged. A muffler shop can do a pressure check on them.
 
1 - 7 of 7 Posts
Top