Ford Mustang Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello! I have an odd situation that I am hoping you can help me better understand. I will try my best to describe what my car's system is doing as I don't know much about car audio.

I have a 2006 GT 'vert with with the Shaker 500 8" door subs. I am in the process of gradually stripping out the factory system and going aftermarket. The subs and amps are the only things left. Not too long ago, I had a Kenwood DPX501BT installed to replace the factory head unit that decided to permanently eat a disk. Everything worked great, except I couldn't use the Kenwood's crossover and sub controls. The mobile install place said I wouldn't be able to use those controls until I got rid of the factory amps. Recently, I replaced all the 6 x 8 door speakers with Pioneer TS-A6885R's, front and back. My b/f installed the 6 x8's as they were a simple swap from the factory ones. Everything sounded great. However, I noticed something weird. I'm not sure if it was doing it before, or I'm just noticing it now because of the better door speakers. I noticed that the right subwoofer is being funny. With the balance at center, both subs fire. With the balance all the way to the left, both subs still fire. However, with the balance all the way to the right, no subs fire. Is that normal? Is this something I should bring up to the mobile install place? It's not like I would ever keep the balance off-center, but I just thought it was weird.

Also, when I get the factory subs/amps replaced, I'm thinking about going with the direct replacement/upgrade Kicker Shelby 8" subs. I've heard good things about them and they don't require any sort of modification to the doors. I know the factory amps won't be able to drive them which is fine. I will have the place install a new amp at the same time.

Thank you for all your help!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
Nobody? Looks like I'll call the installation place, or just live with it, since it's fine if I keep things on center.
 

·
Registered
Joined
·
2,413 Posts
yes it is weird sorry I can't offer any advice on this issue hope the installer was able to offer you some
 

·
Registered
Joined
·
1,184 Posts
If the installer told you that "you couldn't use the Kenwood's crossover and sub controls until you got rid of the factory amps"' It sounds like it has something to do with the wiring. Sounds like you will have no problem, as soon as you replace the amps. Just my opinion.

I also replaced my factory speakers with pioneer brand, and was very pleased with the sound. Good luck with your project.
Let us know when your situation is resolved.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
If the installer told you that "you couldn't use the Kenwood's crossover and sub controls until you got rid of the factory amps"' It sounds like it has something to do with the wiring. Sounds like you will have no problem, as soon as you replace the amps. Just my opinion.

I also replaced my factory speakers with pioneer brand, and was very pleased with the sound. Good luck with your project.
Let us know when your situation is resolved.
Thank you, I plan on doing the sub/amp swap as soon as I can save up some $$$. I actually now have to get the back bumper painted because I caught some kids leaning all over it and one left butt scrapes all over. Luckily I only have a $50 comprehensive deductible and my insurance already cut me a check. The body shop that I go to gave me an estimate of $600 to do the back bumper so that low deductible is definitely saving me money. I swear I'm going to start carrying road cones and caution tape to put around my car when I go anywhere. It's not enough that I park as far away from everybody as I can.
 

·
Registered
Joined
·
3 Posts
Your subwoofers should work just fine now!


I just installed a Kenwood DNX6190HD in my 05 Mustang convertible (has the Shaker 500 system). All my factory speakers work, including the subs and amps. I used a Metra harness and voltage convertor I got from Crutchfield.


See attachment.
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Your subwoofers should work just fine now!


I just installed a Kenwood DNX6190HD in my 05 Mustang convertible (has the Shaker 500 system). All my factory speakers work, including the subs and amps. I used a Metra harness and voltage convertor I got from Crutchfield.


See attachment.
Well, since I posted this originally, the passenger door speaker has started to cut in and out, and the sub on the same side is barely pushing at all. Something is definitely up with the setup and I suspect one of the factory amps is fried/not working properly.

I have a pair of the Shelby/Kicker 8" woofers coming in the mail tomorrow and have an appointment next week at an installer to swap out the factor 8's, the front Pioneer 6 x 8's, and the two factory amps for a single higher powered amp, as well as dynamat the ever-loving bajeebus out of the doors. I'm not sure on which amp to get, since I can't find much info about the Shelby/Kicker 8's online. I will see what the specs say when they come in. I honestly don't know much about car audio at all, so I'm kind of at the mercy of the install place, but they've been around since the 90's doing competition and whatnot, and the owner seems to really care about customer satisfaction/saving money, over pushing $$$ down people's throats.

If anybody has a suggestion on what amp to get I would be glad to hear it. I'm not going to be running any subs in the trunk - I need my trunk space. I'm also hoping to be able to hide the amp somewhere because I'm going for a "stock/classic" feel for my baby and I don't want to open up the trunk and be like "oh look...amp..."

 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Well, it turns out the the Shelby/Kicker 8" subs are just slightly modified Kicker CompVT's. The install place said they just took the plastic backing off. I picked up my baby today and when I walked in the guy said "Loudest door speakers ever..." They sound amazing! He paired them with an Alpine PDR-F50 4-channel amp and Alpine SPR-68 6x8's and went nuts on the doors with Dynamat. We went with the 4-chanel amp in case I ever want to add another sub in the trunk down the road, but I don't imagine ever needing it. I can't believe how clear the sound is. I've honestly never been in a car that sounded so nice, even remembering my days back in the late 90's with 2 12" subs in the trunk.

I've read mixed reviews on the Shelby/Kicker 8's, so I was a little nervous. I've read that they "aren't as loud as the stock subs," or aren't crisp-sounding. Not sure what those folks heard, but if you put them on a nice amp with a good aftermarket head unit they sound fracking amazing. And I have ears that are overly sensitive to higher pitches. I don't need to set off car alarms with my system (I grew out of that 15 years ago), but I do like to listen to my music loud. I listen to multiple genres, from classic rock to goth metal to dubstep and it all sounds amazing.

I would recommend them to anybody who is curious about them. It's a shame there isn't much info online about them. Even the install guy couldn't find much.
 
1 - 8 of 8 Posts
Top