Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
359 Posts
Discussion Starter · #1 ·
I posted this in the "sweet engine smell" thread, but since I am currently in an ongoing saga with my dealership, I figured I would start a thread that maybe more accurately describes what I'm experiencing.

Under hard acceleration (read: anything above 4k RPMs), I am smelling this somewhat sweet smell that sorta smells like coolant. Engine temp is fine as the dial is setting right in the middle even in this God awful weather. I don't gas it hard until everything has warmed up for a few minutes, but even with AC on and recirculating the air, I can smell it, especially after I slow down.

Anyone successfully experience and solve this problem?
 

·
Registered
Joined
·
5,089 Posts
might be different but i had the same issue with my 95GT. turned out to be a pin hole leak in a coolant hose and would only squirt out under presser or high rpms.
 

·
Registered
Joined
·
650 Posts
You are gonna hear all kinds of answers. This has been discussed many times on more than one forum. The answers have been everything from exhaust fumes, to tire rubber, to a "burning" smell from the engine bay, to the factory coating, etc etc. Best thing you can do is take it to another dealer and get it duplicated and see what they say....
 

·
Registered
Joined
·
359 Posts
Discussion Starter · #4 ·
Tonight when I got out of the car, it was pretty strong too. Pretty annoying...hope the dealership has the answer.
 

·
Registered
Joined
·
359 Posts
Discussion Starter · #5 ·
Turned out to just be the cats...at least according to the tech that road with me. He said it was normal and put it up on the lift to see if there was anything wrong, but do you guys ever get a smell from your exhaust under hard acceleration?
 

·
Registered
Joined
·
650 Posts
Turned out to just be the cats...at least according to the tech that road with me. He said it was normal and put it up on the lift to see if there was anything wrong, but do you guys ever get a smell from your exhaust under hard acceleration?
I have... before and after i put ATAKS on. Like I said before, you will get plenty of answers. I took mine to the dealer and the told me it was normal. :smoke:
 

·
Registered
Joined
·
359 Posts
Discussion Starter · #7 ·
I have... before and after i put ATAKS on. Like I said before, you will get plenty of answers. I took mine to the dealer and the told me it was normal. :smoke:
Yeah...normal is such a loaded description :) Oh well, that is the least of my worries right now. After loading up the 87S tune, I am now hearing a "clicking" sound...SMH.
 
1 - 7 of 7 Posts
Top