Ford Mustang Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
soo i guess ill tell you what i got 08 v6 i think its basic...i have black 18x8s with 235/50s on them. well ever since i got them my steering wheel shakes badd. i have had these for about a year. i have had them rotated balanced about 2 times since then, and being the most recent i got an alignment rotation and balance saturday. it still does it pretty bad. it doesnt affect my driving but once i get up to about 50 i get kinda worried. i mean is something going bad? my steering wheel column or somethin? just tryin to see if i can fix it or if i would need to pay someone to check it out. thanks guys :)
 

·
Registered
Joined
·
225 Posts
You have a problem with either bent/crooked rims, out of round tires or if you`re really unlucky, both.
There is also an outside chance the whee land tire combo was not properly balanced.
 

·
Registered
Joined
·
1,275 Posts
There’s retaining clips on a couple of the wheels studs per wheel to hold the rotors in place during manufacturing. If the tire shop failed to remove those and the new rims don’t have cutouts to allow for them your wheels will wobble as you go down the road. Simple fix if that’s what it is. Don’t wait too long to have it checked, if that’s it the wobble can cause premature wear in other parts.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #4
thanks for the fast responses :)

Michael F: im pretty sure there not bent or crooked and the tires are round. or could there be a real slight mess up?


Stars: is there like a tutorial on how to do it? im some what mechanically savy well id like to think haha. or would you think its best for the shop to see?


ohh and since i got them blanced the car doesnt really shake its just the steering wheel
 

·
Registered
Joined
·
1,275 Posts
Easy to check yourself. Just pull the wheel off and look at the studs to see if they still have the push-on clips. If so get out a pair of big dikes (diagonal pliers) and go to work removing them.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #6
Easy to check yourself. Just pull the wheel off and look at the studs to see if they still have the push-on clips. If so get out a pair of big dikes (diagonal pliers) and go to work removing them.

okk and its on all 4?


if they arent there what else could it be? bent rim?
 

·
Registered
Joined
·
1,275 Posts
From the factory the clips are on all four wheels (two clips per). All it would take is for the wheel shop to miss removing one though for you to have problems. Best to check all four wheels just to be sure. If that’s not it then as stated by Michael F there’s likely problems with the rims or tires. Since you drove it for a year with it like that there's also a chance that something else may've been effected by now.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #8
ok i think it may be the clips. because i got these off my buddy who works at discount tire. and when i first got them he had some real small tires on them and we just put them on in his driveway. so i would gues the shops didnt even take a look at them.
 

·
Registered
Joined
·
1,532 Posts
Doesnt really sound like its a tire problem, it could be but seeing as you have had them balanced 2 times, Idk. You should throw your stock wheels back on just to verify. If the shaking is gone then you know its a tire wheel problem.
 

·
Registered
Joined
·
5,818 Posts
1 clip per on my 06.
Very common issue when using aftermarket wheels.

You can see it on the stud in the 2 o'clock position
 

Attachments

·
Registered
Joined
·
69 Posts
Discussion Starter #11
ok i think i see it in the picture could someone maybe circle it so i know fore sure....i talked to my buddy who works at discount tire and he said its proly the clips. and i think friday im going to take it in to him so he can check it out for me. thanks for all the help guys anymore suggestions ill take!!!!!:bigthumbsup
 

·
Registered
Joined
·
5,818 Posts
Sure thing.
I use to have one with it circled, got lost in my unorganized favorites folders, lol.
 

Attachments

·
Registered
Joined
·
26 Posts
I had some shaking not to long ago, i had taken it to Conrad's and they told me it wasn't so much my tires, but my ball joints were going bad. My steering felt "delayed" before i replaced them.
 

·
Registered
Joined
·
10 Posts
I've had to balance my tires 4 times before they got it done right. I took them to Walmart 3 times and I kept having the same problem. Finally took them to my buddies show and they took the time to do it right. I don't know a lot about balancing tires and the machine they use but my friend had to use some different setting on the machine. I think it was like "static" balance or something. I could be completely wrong.
 
1 - 15 of 15 Posts
Top