Ford Mustang Forum banner
Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello, i just replaced heads on my car from stock heads with gt40 heads,60 0ver motor , new headers, h pipe, underdrive pullies it has a kenne bell twin screw supercharger, we replaced plugs, mechanic gapped them at.60 the same gap as the plugs that were in the gt 40 heads we are getting popping thru exhaust on drivers side is this timing or are plugs needeingto be re gapped possibly .45.he set timing at 10 degrees before top dead center but doesnt seem to be right havent had it on road yet.any ideas on gapping and timing, also we used same number plugs that were in gt40 heads not the ones that were in stock heads autolite 25 thanks again john
 

·
Registered
Joined
·
5,170 Posts
Autolite 24's and about 35-45 gap. Just experiment with the Gap.

But anywhere between there, you should be good. What ignition you running?
 

·
Registered
Joined
·
46,010 Posts
That .060 gap is way too much with boost. Bring it back down to .035 - .040.
 

·
Registered
Joined
·
2,244 Posts
I would get rid of the Autolites for one, a set of Denso Iridium go one step colder then what yourr stock plugs are. As for your timing, back it off two degrees. You might have to play with the timing, as for the gap no more then 45 degrees and don't forget one step colder. When you tune this, make sure you do it on a dyno for full potential and no unsuspected popping from anywhere, Mike. SCT Tuner.:bigthumbsup P.S. As for the Densos, they may be costly but well worth the money. I know a few friends of mine, that are on their second and third season with no problems. My own is on it's third season, and consistant 1.09 60 ft times at 7.973 at 183.897mph. Mike.
 
G

·
I am a firm believer in autolite plugs have always had good luck with them....

Mike if I buy a set of denso's and don't like them will buy then from me.......:gringreen
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
just regapped plugs to .045 and still same thing pops at idle when you give it gas just doesnt rev up smoothly, is it possible timings of a tooth or two or out 180 degreese
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top