Ford Mustang Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
ok so my 2000 gt seems to be having trouble when actually going down the road......it idles fine but once i get it out on the road if i go to get on it it does this rough sputtering thing.........then if im just cruisin in 5th it feels like my whole car is shaking at about 60mph.......its weird and i cant seem to figure out whats goin on since it doesnt do this everytime i drive it.........any help would be appreciated since i know it may be hard to really be able to tell since im having to explain this through the internet
 

·
Banned
Joined
·
3,705 Posts
Any CEL's coming on?
Not much info to go on. Could be a billion different things.
Check air filter/plugs/COPs/fuel filter/bad fuel....etc...
My brother had a truck that did something similar when his cats went out too.
Like you said, could be hard to diagnose on the internet w/o more info.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
there are no lights on everything else is fine no overheating or anything.........if it was my cats wouldnt a check engine light come on??
 

·
Banned
Joined
·
3,705 Posts
yeah, if it was your cats your rear O2 sensors would pick it up and let you know something was jacked up.
Check out your basic tune-up stuff and start narrowing things down.
 

·
Registered
Joined
·
45 Posts
could be the egr valve. My thunderbird is doing the same thing. Had advance do a scan on it and they said it was an egr code.
 

·
Registered
Joined
·
57 Posts
Try checking all your coils and seeing if any of them are breaking down. At the shop i work at 4.6 and 5.4 coils are pron to got out and cause a miss and of course it would only show up in 5th gear or under a heavy load. You also might want to check plugs and if all the coils test good i would put some boot kits on them. When checking the coils just dont measure resistance but also put them on a sun machine and put them under stress.
 

·
Registered
Joined
·
12,664 Posts
when was the last time you changed the fuel filter?
 

·
Registered
Joined
·
9 Posts
My 99 gt was doing the same thing a few months ago, The coils were in bad shape ( greenish corrosion) on the springs inside the boots, Cleaned all of them and has been fine since.
 
1 - 9 of 9 Posts
Top