Ford Mustang Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Squealing and stumped>>>99 gt..new clutch<flywheel<tob<pilot bearing!!

Hey Guys....Hope you have some infinite wisdom for me because i really want to drive my stang and im not because of a high pitch squeal.....
Currently at a professional shop so i thought... my car squeals at 1500 rpms and above.... mechanic diagnosed bad pilot. It is rather loud coming from trans area. Took belt off and started so i know its not belt or pullies. Put in brand new flywheel,clutch,TOB, and pilot figured that would cure it. Well after a mile and a half of driving its back.... a squeal above 1500 rpms...clutch depressed,pressed,in gear,out of gear...the only time it wont squeal is under 1500 rpms... i can drive it without it squealing....under 1500 rpms....WHAT GIVES!?!?!?!?!??!?!?:cursing:
Still at shop and dont know if i should have to pay for something that isnt fixed.... i am hopin he will get it but should i pay for all the work and parts when that didnt fix the problem?????:?:
 

·
Registered
Joined
·
18 Posts
Discussion Starter #2
Seriously Guys!!!!!!!!!!!!!!!! A lil love would be great and im not gettin any here at all..... c'mon..... gimme something to grab at....WTF....frustrated and ready to kill my mechanic!!!!!!!!!
 

·
Registered
Joined
·
2,288 Posts
Is the clutch cable and quadrant stock ??

I put in a new clutch kit around 80,000 miles put around maybe 1,000 and the throwout bearing went bad on me only thing i could have thought of was the factory clutch cable and quadrant i was having a little problem with it staying adjusted it would keep moving on me not alot to my feel but i guess it doesnt take much to cause the pilot bearing to ride on the pressure plate. So i got on summit ordered a steeda kit for about 110 bucks went home for christmas break pulled tranny and such installed new throwout bearing and pilot bearing cause i wasnt 100% sure on which it was till i got the tranny out and pulled the tb out and yeah it was shot im at 90,000 miles now and not a problem so far.

Also just to throw it out there you dont keep your foot on the clutch pedal at all while driving do you ??? Even though just a short drive shouldnt kill a tb !!!

Did you happen to ask your mechanic for your old parts to look at them ??? That could easly help diagnose your problem !! Good Luck !!
 

·
Registered
Joined
·
2,288 Posts
Does the sound get louder with higher RPM's ????

Where exactly does the sound seem like its coming from to you have someone rev it while you listen ???

Not being able to be there we need more info on the symptom to help you out its very hard to diagnose let alone help someone with a problem over a forum with little info other than a squeal noise coming from your car !!!
 

·
Registered
Joined
·
2,288 Posts
I dont see anything about a pressure plate being added why not ???
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
sorry for the delay... i solved the problem myself and wanted to post for everyone to see incase someone runs into similar problems.
The squeeling would on come on after 1500 rpms and would get louder as the throttle increased. The noise coming right out of the bell housing area. Well when i bought the car it had a cold air intake on it already. On the drivers side there is a pvc elbow to let crank case fumes to be drawn out by your CAI via a pvc tube running across motor to a female plug. Well this dumb ass ran it to the IAC!!!! Now we all know the IAC stops working at 1500 rpms and is also piped over to the CAI. Well he had the crank case elbow fitted to the IAC via a rubber hose....after 1500 rpms the crank case built up too much pressure and the squeel was the air escaping from the rear main seal!!!!!!!!!! Simple fix but now have new clutch and everything that goes with it.....700.00 for a 10.00 fix.
Thanks for the reply and the interest in helping me.
 

·
Registered
Joined
·
2,288 Posts
Wow yeeeepppp i can tell you now that never woulda come to mind to me see what i mean lol its hard to help with things over a forum lol but im glad you got it fixed man!!!
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
been a while since ive been on...thanx for the replies and the help man...says alot!!!
 
1 - 8 of 8 Posts
Top