Ford Mustang Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have recently installed new steeda underdrive pulleys on my 97 mustang. i had to get a 1/2" shorter belt only now the pulleys keep cutting the belt along the inside of the belt. i have asked around about this and im thinking it is the alignment of the pulleys. Does anyone have any in put on this??? thank you
 

·
Registered
Joined
·
6 Posts
Huh that's odd i just got mine put on about a week ago and have no problems at all I live I
Phoenix az where it's 105+ everyday no coolng or charging problems that other people have mentions which are the most common of them. Is it cutting along the water pump pulley I'm not sure if our set u is the same I got a 99 gt but I know a buddy of mine had problems cause it kept slipping off somehow and it was the water pump pulley so I'd check that and try and see where it rubs Nd look for clearance issues
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
yeah im down here in Yuma, and im pretty the shop that said they could do it just messed up somewhere along the way installing them. and just to make sure the water pump pully is right under the tensioner right?
 
G

·
Welcome to AFM! That's strange that you had to get a shorter belt. Normally the stock belt is just fine. Is your car a GT? Thanks for joining!
:bigthumbsup
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
yeah is the 97 gt im being told by others it's the alignment of the pulley thats causing the tear in the new belts
 
1 - 5 of 5 Posts
Top