Ford Mustang Forum banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I recently had my stereo stolen and needless to say it was not a pretty sight of wires afterwards. Everything from lights to alarm to speedometer went out. After attempting to put everything back together (wires) everything was working well. Only one minor thing, the lights did not flash completely when locking the car with the remote, but rather dimly turned on.
Couple weeks later and my power went completely out while driving. It was the EEC fuse. I replaced and worked with no problem. A week later and it goes again. Then, to top it off, when i tried to turn on the car after replacing the EEC fuse, the car seems to activate the alarm when I try to turn it on and wont let me run it. After removing a fuse that seems to lead to the alarm, the car will start smoothly, but as soon as I shift gear the motor will rattle and the car runs slow and eventually goes out. Its very frustrating not sure if anyone out there has been there before and can advise on this problem. My car is a 94 Mustang V6 3,8.
 

·
Registered
Joined
·
437 Posts
Sounds like someone did one serious number on your car. there are so many things that could be wrong judging by what you are describing. Best thing to do is get that puppy to a dealership and have them go over it with a fine toothed comb. Might be expensive but if you want to keep your car....:sosad:
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top