Ford Mustang Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
This problem I have only happens sometimes. Sometimes when slowing to a stop no matter how slow or how fast I'm rolling the idle is really low and sometimes dies until i come to a complete stop. when im at a complete stop the car idles fine. It only does this when im in nuetral slowing to a stop. Thank for the help..
 

·
Registered
Joined
·
436 Posts
hey, welcome to the forums.....first we need to know what year is your car and what mods u have, is it an auto or 5 speed, etc.....there have been a lot of posts on weird idles so u might want to do a search....one of the main things it could be is disconnected vaccum lines underhood, loose airfilter, IAC or PCV valve....u might want to check all these things first....also, how many miles does your stang have....have u tried a fuel system cleaner or some sort of treatment u can put in the tank...first thing i would do is check all vaccum connections and check the filter.....then check the IAC and PCV valves....a lot of people have had to replace these parts to stop the problem.....let us know
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
I have AEM RAM air intake, 40's Flowmaster, hypertech powerprogrammer.
 

·
Registered
Joined
·
5,631 Posts
Do you have an auto trans?

Just guessing, of course, but my vote would be on a vacuum line (split lines are tough to find unless you trace and disconnect/examine each one). If you have an auto tranny, it might be other things...
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top