Ford Mustang Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
72,878 Posts
Discussion Starter · #1 ·
Brought her in tonight for TSB 05-9-11 (popping struts). Funny it took until yesterday to show up (on both sides). Actually put the stock intake and tune back in to make sure I don't have any warranty issues. Hope they get it squared away tomorrow.
 

·
Registered
Joined
·
110 Posts
mine pops but only when I turn a certain directions... I think it's when I pull out of my driveway and make sharp left turn slowly it pops... weird thing is I have tokico shocks/struts... no idea what the popping is for me!!!
 

·
Registered
Joined
·
2,479 Posts
2k5stang said:
mine pops but only when I turn a certain directions... I think it's when I pull out of my driveway and make sharp left turn slowly it pops... weird thing is I have tokico shocks/struts... no idea what the popping is for me!!!
I bet it's the standard Mustang front end popping. It's always at very slow speeds like it a parking lot, right? If your car was built before February or so you'll have it. There is a TSB and they replace some front suspension parts (NOT shocks or struts). Mine started popping shortly after I received my car in October 04. It got worse and worse but Ford would not do anything about it because it was a known issue and they were still working on the fix. After I took it in for the TSB fix it hasn't popped since.
 

·
Premium Member
Joined
·
72,878 Posts
Discussion Starter · #4 ·
Got it back today. All fixed as far as I can tell. Reinstalled the C&L and reflashed the ECM.
 

·
Registered
Joined
·
516 Posts
hate to drag up a dead thread but! i bought my car a week ago monday. and the past 3 days i noticed that if i park the car for a little bit, then get back in and start the car i hear a pop. its happened when the car was still parked and twice when the car was rolling. think it could be the same thing?
 

·
Premium Member
Joined
·
72,878 Posts
Discussion Starter · #6 ·
88_stanga said:
hate to drag up a dead thread but! i bought my car a week ago monday. and the past 3 days i noticed that if i park the car for a little bit, then get back in and start the car i hear a pop. its happened when the car was still parked and twice when the car was rolling. think it could be the same thing?
Shouldn't be... The permanent fix was rolled into the 06 production line. But I suppose anything is possible. I would take it in to make sure.
 
1 - 6 of 6 Posts
Top