Ford Mustang Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey i'm new here thought I would see if you guys could help me with my problem. I have a 1966 mustang coupe 289 with 3-speed manual transmission. At first it wasn't letting me shift into 2nd sometimes, now its stuck in neutral and wont let me shift into any gear but when I turn my car on it acts like its in 2nd. The only thing I have tried so far is check the transmission oil but seems like its full so if you guys have any other ideas it would be a lot of help.
 

·
Registered
Joined
·
2,397 Posts
Hey i'm new here thought I would see if you guys could help me with my problem. I have a 1966 mustang coupe 289 with 3-speed manual transmission. At first it wasn't letting me shift into 2nd sometimes, now its stuck in neutral and wont let me shift into any gear but when I turn my car on it acts like its in 2nd. The only thing I have tried so far is check the transmission oil but seems like its full so if you guys have any other ideas it would be a lot of help.

Hi and welcome new guy.

Have you jacked it up and looked for any undo looseness or linkage arm(s) not connected? If it's all still there and looks normal, then, have someone try shifting (clutch depressed), while you observe the linkage. My first impression is a linkage arm was working it's way off the shifter pin and, finally, become dislodged. If this is the case, it should be an easy fix.
Otherwise, if it's all looking normal on the outside, it's probably a shifting fork jambed, possibly broken internally, this is not good.
Good Luck!
 
1 - 2 of 2 Posts
Top