Ford Mustang Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter · #1 ·
Today the battery light came on..went to auto zone and the battery and alternator checked out alright. I kept driving home and the car went crazy. The windows when you open the door will not lower a little like before, the alarm will go off, the car will hesitate, the brake lights stopped working. I never had any problems before, ever. I had my 2011 delivered so maybe my old car is jelous. Any one had this happen to then before?
 

·
Registered
Joined
·
1,274 Posts
You could try disconnecting the battery for 15 minutes and see if that helps reset something. Make sure the battery terminals and lugs are clean metal where they contact each other. Beyond that I’d hate to start speculating. Both the SJB and the PCM sound like they’re being affected by something. Any recent exposure to moisture in the engine bay (like a hosing of)? Any water leaks on the passenger side? Was Autozone thorough when they checked the alternator and battery?
 

·
Registered
Joined
·
266 Posts
Find a Catholic priest and have him perform an exorcism.:rollgrin:

If that doesn't work check for a bad ground. You'll probably find one that's corroded or loose.
 

·
Registered
Joined
·
145 Posts
Find a Catholic priest and have him perform an exorcism.:rollgrin:

If that doesn't work check for a bad ground. You'll probably find one that's corroded or loose.
hahaha :grinroll:

Try disconnecting the battery like he suggested. if the car still shows it try to read what error codes it has with an SCT or take it to autozone so they can tell u what error codes its trowing
 

·
Registered
Joined
·
266 Posts
Did you get this fixed yet ? What was wrong ?

Inquiring minds want to know..............
 

·
Registered
Joined
·
207 Posts
Discussion Starter · #6 ·
I relly dont know what caused it, but I took it to the dealer and they said the batt was bad an so was the alternator. They fixed it under warranty and the batt light went off and the car is running like a baby. But it was very weird and I dont believe either was the problem and it was right during a very strong thunder storm.... go figure. I hope it doesnt happen again.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top