Ford Mustang Forum banner

1 - 5 of 5 Posts

·
Registered
2007 mustang 4.0
Joined
·
17 Posts
Discussion Starter · #1 ·
So back in March I had this problem where a hose came off the plastic thermostat housing because the clamp was on too high... at least that’s what my mechanic told me when he fixed it. Anyway, the same exact problem is back. Coolant is once again splatted all over my engine bay but I can’t find the hose that is loose or detached. Is the thermostat housing supposed to have an o-shaped opening right next to the sensor? I don’t know if that’s my problem or not but it might be coming from somewhere else in the coolant system. Any help is greatly appreciated, thanks.

image.jpg image.jpg
 

·
Registered
2007 mustang 4.0
Joined
·
17 Posts
Discussion Starter · #3 ·
Cracked plastic housing. Common problem on 4.0L SOHC engine built in Cologne, Germany.
I dont think it's that though. Same problem happened about 2,000 miles ago and was fixed by mechanic when he tightened a hose. I read that cracked housing is also a slow leak and not a sudden burst
 

·
Registered
Joined
·
1,347 Posts
Start it up and see where it's coming from. If it's unclear when it's running then once it's warmed up and turned off it should be audible and you'll see steam too.
 

·
Registered
Joined
·
3,714 Posts
Warm the engine up to normal operating temperature and then shut it off. Any coolant leaks will immediately become apparent as the system will have become pressurised.
 
1 - 5 of 5 Posts
Top