Ford Mustang Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
i have a 2000 Mustang GT i just recently installed a 75mm throttle body and upper intake plenum (both Power Products) the only reason i picked these 2 is because they were on craigs list cheap, so i couldn't pass them up, but anyways...i have been having problems with bad idling (700 rpms down to 500rpms and then back up to around 1000) and then it would stall..i would come to a stop and my car would just die...i put a new idle control valve on and that still hasn't fixed the problem...my next step was to go ahead and replace the throttle control sensor to see if that would do anything...any other suggestion please let me know before i take these two off and sell them and just put the stock back on..another question is what are the barbed fittings that come with the upper intake plenum for?.. should i try using the bigger sized one?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
thanks alot for all the input i will try to do some of the things listed above when i get a chance, and i will post an update with the results...i have had the battery off for a full day to let it reset, i put it back on and let it idle to the normal temp, idled great...i took it for a drive and played around alittle in it and then came to a stop and it would idle really low (500 rpm) or just stall...should i try and switch the gaskets out with new ones?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
how do i go about checking that?..would it help to try and replace the TPS?..also i talked to a place around where i live that work on mustangs, and he seems to think i need to have my car tuned, could this also be a problem or is he trying to get my money?...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #14 ·
well i still am having problems with the car!!.. i installed new gaskets, new TPS and idle control valve...had the battery off and everything...started it up, idled great, no hesitation or anything...took it out for a drive and it was doing good...took it on the highway and hit about 110 to open it up, came to a red light and what do you know it died!!!im wondering if i should just take everything off and put the old stuff back on. let me know if you think of something else to try...should i try and put hose clamps on all the hose's to make sure everything is tight?...its really getting aggravting...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #16 ·
still need to let the computer adapt.the mix is controlled in cells.which is better understood as events,stopping from high speed is not the same event of stopping from normal speed.takes a few different trips,driven slow,normal,fast,to let the computer adapt,so if is driving ok at regular speeds and then,all the sudden,it's stall while stopping from high speed at the first drives,it is not a biggie.start it up again and let it eat.this is all making sure there is no vacuum leaks,(hoses disconnected,bolts torqued uneven,teared or broken gaskets),electrical connectors disconnected or incorrect idle screw adjustment.differs with the engine,there is no written specs.with the iac disconnected try to reach minimun engine speed without surging or stalling,move the screw slowly.the last is to adjust the idle screw.rev the engine in betwen adjustments.then when you get it right, find the next chevy and beat him up.:bigthumbsup
i'm thinking the idle set screw is messed up, i tried to mess with it and i couldnt get it to idle good at all, it was either way too high or way to low...so all in all i just took the throttle body and plenum off and they are both going on craigslist...i put the factory parts back on and the car is running great...by the time that would have set itself to the settings it needed my starter was gonna go out, it got to the point where it was having trouble starting, so i took the easy way out..thanks for all the help, but i guess im no mechanic when it comes to this kind of stuff
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top