Ford Mustang Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
So I picked up this billet throttle body for a good deal. I took my time on the install to make sure every thing was in order including tune and setting the tps to factory specs. No matter what i do my car goes into fail safe mode. I contacted bama tunes and they told me to check the installation so i did but still no luck. I switched back to the stock throttle body and everything worked. While messing around with this stuff i found that the screw that sets the tps is a little different. I have some pics of them taken out to show you what i mean. The stock screw has a spring loaded pin at the bottom while the new one has non. I think this is the problem because it seems that when u turn the key to power on the computer does a system check and it closes the throttle body witch is allowed by the stock tps screw. It also explains why i would be get p2104 and p2112 codes which means the throttle actuator control system is stuck closed and forces idle. I'm not sure if this is the problem but its the best think I could think of. I'm considering drilling out a hole into the new throttle body to make the stock screw fit. ANY HELP OR SUGGESTIONS WOULD BE GREATLY APPRECIATED!!! Thanks!
 

Attachments

·
Registered
Joined
·
5,881 Posts
So I picked up this billet throttle body for a good deal. I took my time on the install to make sure every thing was in order including tune and setting the tps to factory specs. No matter what i do my car goes into fail safe mode. I contacted bama tunes and they told me to check the installation so i did but still no luck. I switched back to the stock throttle body and everything worked. While messing around with this stuff i found that the screw that sets the tps is a little different. I have some pics of them taken out to show you what i mean. The stock screw has a spring loaded pin at the bottom while the new one has non. I think this is the problem because it seems that when u turn the key to power on the computer does a system check and it closes the throttle body witch is allowed by the stock tps screw. It also explains why i would be get p2104 and p2112 codes which means the throttle actuator control system is stuck closed and forces idle. I'm not sure if this is the problem but its the best think I could think of. I'm considering drilling out a hole into the new throttle body to make the stock screw fit. ANY HELP OR SUGGESTIONS WOULD BE GREATLY APPRECIATED!!! Thanks!
What brand Throttle body. Did you set the Tps VOLTAGE the same as the stocker?
 

·
Registered
Joined
·
22 Posts
Yeah I love how they say they don't, but I did get a tune but it still goes into failsafe mode.
Did you replace the gasket when you swapped the throttle bodies out ?

I just read that you checked the voltage to make sure it matched the stock one. That would be my first thing to check but if you have done this I'm kinda stuck.

Have you checked continuity or for proper power on all of the connectors?
 

·
Registered
Joined
·
5,881 Posts
I can`t make it out is there any stampings or indication of what brand it is. IF so you need to get ahold of the manufacturer and talk to them. I also think a tune is in order for the TB.
 

·
Registered
Joined
·
365 Posts
So when u step on it youget no throttle? I had this problem on the otherside of the throttle body there is a cylindrical metal piece you unscrew i. There is the magnet that twists it ope. And closed. Give it a full twist to the left and right then try it. I did that and it fixed the problem somehow
 

·
Registered
Joined
·
37 Posts
Discussion Starter #9
I checked the gasket and its not that...I have also checked all the connections and its not that either. I'm also and still unsure of the brand there's no stamping that I can find so it looks like I'm out of luck with calling a manufacture. The car has no throttle and goes into failsafe mode and runs really ruff. The engine light is on because the car thinks the throttle body is stuck closed so it sounds like the throttle body stays closed but its not stuck and moves freely by hand. The car runs normally with the stock throttle body. I really think it has something to do with the tps setting screw (I posted the picture in my first post)
 

·
Registered
Joined
·
2,250 Posts
So you bought a used TB of an unknown brand from an unknown source (I'm assuming the last part since you can't find out from the seller who made it). Maybe he sold it because it didn't work for him either? Just sayin...

If the stock TB works fine I personally would just stick that one back on and write this one off, but that's just me.

Chances are you wouldn't see any performance gains with it if you can get it to work, unless you bought it just as an appearance mod. My $.02.

Edit: I just pulled up pictures of the MMR TB, the GMS one, BBK, etc and it certainly does look like the MMR one you have.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #11
So you bought a used TB of an unknown brand from an unknown source (I'm assuming the last part since you can't find out from the seller who made it). Maybe he sold it because it didn't work for him either? Just sayin...

If the stock TB works fine I personally would just stick that one back on and write this one off, but that's just me.

Chances are you wouldn't see any performance gains with it if you can get it to work, unless you bought it just as an appearance mod. My $.02.

Edit: I just pulled up pictures of the MMR TB, the GMS one, BBK, etc and it certainly does look like the MMR one you have.
I did get it mostly for looks...I also looked up some pics and can"t quite say which brand it is either....it's driving me nuts because I can't find anything wrong with it....it just doesn't seem to work on the car.
 

·
Registered
Joined
·
2,250 Posts
I did get it mostly for looks...I also looked up some pics and can"t quite say which brand it is either....it's driving me nuts because I can't find anything wrong with it....it just doesn't seem to work on the car.
I'd give MMR a call, because I'm about 95% sure it is a MMR TB. It just doesn't look close to any other aftermarket tb except theirs. Hopefully they can help you sort it out since they have a decent reputation. Maybe (probably?) it does have something to do with that screw.

Good luck :bigthumbsup
 

·
Registered
Joined
·
37 Posts
Discussion Starter #13
I'd give MMR a call, because I'm about 95% sure it is a MMR TB. It just doesn't look close to any other aftermarket tb except theirs. Hopefully they can help you sort it out since they have a decent reputation. Maybe (probably?) it does have something to do with that screw.

Good luck :bigthumbsup
Thanks, I thought so too, I actually did call them about a week or so ago but the tech guys were not in at the time but the guy on the phone was really nice...he said he had no idea if they made them and said they would get back to me but never did.....Anyway I got the throttle body to finally work today by fitting the stock tps screw into the new throttle body. The car seems to run fine now and revs up faster then before but I haven't got a chance to test drive it.
 
1 - 13 of 13 Posts
Top