Ford Mustang Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
711 Posts
Discussion Starter #1
I got it off till the bottom. How do I get that bottom part off so I can get the rest of the belt off?
 

·
Registered
Joined
·
711 Posts
Discussion Starter #3
Do you have to remove the bolt holding the thing on?
 

·
Registered
Joined
·
42 Posts
yup the big bolt in the middle of the crank pully... then get a puller for the hub... then take off the crank trigger and belt will come right off...
 

·
Registered
Joined
·
711 Posts
Discussion Starter #5
yup the big bolt in the middle of the crank pully... then get a puller for the hub... then take off the crank trigger and belt will come right off...
It moves an awfull lot. is it ok? Does it loosen to the left or right? Can I do it with a breaker bar?
 

·
Registered
Joined
·
42 Posts
ok use a breaker bar... the easy way is to lean the bar up against the driver side on the fender if possible then crank the motor for a sec and that will break the bolt loose... otherwise try it with the serp belt still on but i think it will slip still... i did the breaker bar way up against the fender and it worked... just put a rag down so it dont hurt nothing...
 

·
Registered
Joined
·
711 Posts
Discussion Starter #7
I'll def. do that when the lights out in the am. The crank position sensor is rusty from the water pump before I replaced the thermostat and gasket. How can you tell if it's bad?
 

·
Registered
Joined
·
42 Posts
well if ur car runs still the sensor is fine... lol... if its got rust on the inside where the magnet is u may wanna clean it with brake cleaner while its off... just make sure u take ur time so u dont break the sensor cuz they aint cheap... good luck!!!
 

·
Registered
Joined
·
711 Posts
Discussion Starter #9
well if ur car runs still the sensor is fine... lol... if its got rust on the inside where the magnet is u may wanna clean it with brake cleaner while its off... just make sure u take ur time so u dont break the sensor cuz they aint cheap... good luck!!!

That's the problem, It don't run. I'm trying to figure it out, but the timing belt was loose and dry rotted. Should the gears have play in them? It has play like a locked steering wheel.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top