Ford Mustang Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've installed Mutha Thumpr stage 2 cams in my 06 GT 5 Spd. Manual. I've had them in for about 8 months now and the car runs amazing and sounds BOSS! My only problem is now after I let the engine idle in neutral the tranny knocks like crazy! I put my car on a lift last week and listened to the tranny with a stestoscope(most likely spelled it wrong) and the noise is very loud towards the rear of the tranny near the drive shaft; although it can be heard throughout the whole thing. Oh yea, whenever I push in the clutch the noise completely goes away which lets me know its not my engine :) Help! :worship
 

·
Banned
Joined
·
12,436 Posts
probably the throwout bearing....
 

·
Registered
Joined
·
87 Posts
i had the exact same thing happen after my build. turned out my left side cam was 180* out, causing the shock/vibration to rattle the tranny.
maybe cams are TOO thumpy!
 

·
Registered
Joined
·
5,329 Posts
i had the exact same thing happen after my build. turned out my left side cam was 180* out, causing the shock/vibration to rattle the tranny.
maybe cams are TOO thumpy!
What?

OP, check the clearance between the TO bearing and pressure plate, the fingers are not exactly even and if the bearing is riding on the plate...
 

·
Registered
Joined
·
87 Posts
What?

OP, check the clearance between the TO bearing and pressure plate, the fingers are not exactly even and if the bearing is riding on the plate...

What is not clear? Harmonics from the motor are causing the transmission to knock. TOB wont knock when its going. itl make every other noise but wont knock.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Originally after the install I had to have it retuned 2 times! Doesn't sound far off for the idiots to install the cams wrong. Thanks for the advice!
 
1 - 6 of 6 Posts
Top