Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Had this problem start with my tranny today. attached a video, if you cant see, ill be driving and my RPM's will jump up to 5500 and back down and back up again, and as it's doing that i will lose speed, almost as if im going into neutral. If you have any ideas on the issue and solving it please let me know.
 

·
Registered
Joined
·
248 Posts
If its an automatic, your trans is slipping and need to be rebuilt or replaced. If its a manual, you need a new clutch
 

·
Registered
Joined
·
482 Posts
Where do all these "Rebuild your automatic right away" assumptions come from?

I'm guessing it's an auto, since that's a common AOD problem. Does it happen in all gears, just one, going into OD? I'm having a similar problem right now, trying to pin point.

Did you check your fluid level? When was the last time you looked at your filter/oil? Have you adjusted your TV pressure? If all of the obvious stuff checks out, first place I would look is at your VB. If you have dirty/sediments in the oil, it's common for the valves to stick, or gunk to restrict oil passages. I'd clean out the VB and check all the valve travel before tearing down the trans.

If it only happens in OD, then I'd look into the OD band. Very common issue.
 

·
Registered
Joined
·
23 Posts
Transmission slips

What trans do you have?

Suggest you check the fluid level. Also look at the color of the fluid, look for foam, and smell the fluid.

If the fluid is at the proper level and smells burnt, the bands could be slipping.

If the fluid is foamy, level could be be low.

With engine running, put the trans in low, then D, then N, then R, then park, then check fluid level with the engine still running.

If you drain the fluid from the converter and pan, leave about a quart of fluid in the convertor. If you empty the convertor, the pump will dry start which can damage it.
 
1 - 4 of 4 Posts
Top