Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello forum. I’m new here.
2 days ago I bought 2008 Mustang V6 with original 77k miles from a private seller. When I test drove it transmission was working just fine, shifting smoothly into all gears. When I paid and drove off and the car warmed up I started having some issues. When I put in reverse it hesitates and then jerks really bad before shifting. Shifting into D isn’t bad at all, but still has some jerk. It only happens when the car is heated up. When it’s cold everything works fine. Upshifting and downshifting is fine at all times. The ATF was changed recently according to its color. What could be the problem? Low/high on fluid? Valve body? Solenoid pack? Or something more serious? Thank you for answers
 

·
Super Moderator
Joined
·
3,506 Posts
Welcome and thank you for joining ALLFORDMUSTANGS!
Please read the Site Rules and be sure to complete your Account Settings.
We are glad you have chosen to be a part of our community and we hope you enjoy your stay.
 
  • Like
Reactions: 5.0 Coyote

·
Registered
Joined
·
1,347 Posts
Welcome to the site.
Unfortunately, you were taken by the seller. There's no way that he didn't know about this and sold you the car anyway. Some people have no conscience.
Upshifting and downshifting is fine at all times when hot and cold or just when cold? You didn't specify that. You only specifically mentioned the hesitation and jerk going into D or R.
The 5r55s has known issues. The servo bores can wear and prevent shifting normally or even shifting into certain gears at all. In order to fix it they have to be reamed and sleeves installed upon a full rebuild. The shift solenoid pack is also known to fail as well as the front ring gear hub snap ring.
This is discussed on here:
(71) 5R55S Problems | Ford Mustang Forum (allfordmustangs.com)
This can be watched in detail by a trans rebuilder here:
5R55S common Problems - YouTube
You're probably throwing some codes that can help narrow down the issue. I'd get it scanned.
 
1 - 3 of 3 Posts
Top